Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the 2.6.32-32-generic-pae kernel over my existing 2.6.32-32-generic kernel.

This solved the problem I had with the system not showing the full amount of RAM, but it has had a side-effect. I can't start my VirtualBox VMs. I get this message:

Kernel driver not installed (rc=-1908)
Please install the virtualbox-ose-dkms package and execute 'modprobe vboxdrv' as root

virtualbox-ose-dkms was already installed and when I ran sudo modprobe vboxdrv, I got another error message:

FATAL: Module vboxdrv not found.

I purged virtualbox-ose-dkms (complete removal) and then re-installed it, but I still got the same error.

I then repeated the full re-installation, but this time with the previous non-pae kernel. It works, but fails when I reboot into the pae kernel.

Next I uninstalled and then re-installed VirtualBox into the pae system, but it gave the same error.

What can I do to get VirtualBox running with the pae kernel?

share|improve this question
    
possible duplicate of Unable to Install VirtualBox Due to Missing Kernel Module –  Lekensteyn Jun 19 '11 at 19:42
    
I've treid the suggeston in the above-mentioned possible duplicate... I purged linux-headers-2.6.38-8-generic and installed linux-headers-2.6.38-8-generic-pae .. I still get the error. –  Peter.O Jun 19 '11 at 20:00
    
You need to install the headers matching your kernel version. See the updated answer. –  Lekensteyn Jun 19 '11 at 20:04
    
I never had issues when installing Virtual Box from the repository maintained by Oracle: see this answer –  Takkat Jun 19 '11 at 20:15
    
I got it!.. thanks... I think I was installing things in the wrong order... This worked for me... After purging, I installed in this order: sudo apt-get install linux-headers-2.6.32-32-generic-pae,then sudo apt-get install virtualbox-ose, (The reverse order didn't work) –  Peter.O Jun 19 '11 at 20:28
add comment

1 Answer 1

up vote 2 down vote accepted

The issue was solved thanks to the comments to the question... VirtualBox is working again... by uninstalling and re-installing things in the correct sequence.. (I've "answered" in this way, as there was no other specific answer...)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.