Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm not able to scroll by my touchpad after reboot. When I set from System > Preferences > Pointing devices the vertical scrolling, it works till reboot.

My X11 current configuration is:

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen 0       "Screen0"        0 0 
    InputDevice "Synaptics Touchpad"
EndSection

Section "Device"
    Identifier "Intel_IEGD-0"
    Driver     "emgd"
    VendorName "Intel(R) DEG"
    BoardName  "Embedded Graphics"
    BusID      "0:2:0"
    Screen      0
    Option     "PcfVersion"             "1792"
    Option     "ConfigId"               "1"
    Option     "PortDrivers"                "lvds"
    Option     "ALL/1/name"             "lvds-display"
    Option     "ALL/1/General/PortOrder"        "40000"
    Option     "ALL/1/General/DisplayConfig"        "1"
    Option     "ALL/1/General/DisplayDetect"        "1"
    Option     "ALL/1/General/VideoRAM"                 "131072"
    Option     "ALL/1/Port/4/General/name"      "LVDS"
#    Option     "ALL/1/Port/4/General/Rotation"     "0"
    Option     "ALL/1/Port/4/General/Edid"      "1"
    Option     "ALL/1/Port/4/Attr/70"           "0"
    Option     "ALL/1/General/Accel"            "1"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Intel_IEGD-0"
    Monitor       "LVDS"
    SubSection "Display"
    Depth     24
    Modes    "1366x768"
    EndSubSection
EndSection

Section "Monitor"
    Identifier   "LVDS"
    ModelName    "LCD Panel 1366x768"
EndSection

Section "DRI"
        Mode         0666
EndSection

Section "Extensions"
    Option "composite" "enable"
EndSection

Section "InputDevice"
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
     Option "SendCoreEvents"          "True"
         Option "Protocol"                "auto-dev"
         Option "Device"                  "/dev/psaux"
         Option "SHMConfig"               "True"
     Option "HorizScrollDelta"  "0"
EndSection
share|improve this question
    
I set up X11 as you can see because touchpad stopped to work after fn+f7 (disabling it by keyboard). Now it seems to work restoring old x11 conf file, but I'm quite afraid to disable touchpad when I'm using normal mouse. What do you advice for enabling/disabling touchpad easily and successfully, since fn+f7 doesnt enable it anymore? –  Valerio Giuffrida Jun 20 '11 at 6:25

3 Answers 3

up vote 0 down vote accepted

I'm a bit surprised to see a pointer still in the X11 configuration file, that's quite a legacy way of doing things. I expect it is these settings that are overriding the changes you make every time.

Unless you already know you specifically need to configure your device using the xorg.conf (i.e. nvidia drivers) you can try taking the 'input device' section out of the file (don't forget the entry under "server layout" too.)

Backup your configuration before you try this, so if you do lose your mouse you can simply open a terminal (CTRL + ALT + T) and restore the file using the keyboard.

share|improve this answer

Did you check the mouse configuration? My touchpad can be configured by the mouse settings. May be you have conflicting settings. as pointing device is an additional GUI.

enter image description here

share|improve this answer

FINALLY beat this one. All I had to do was open Ubuntu's "Startup Applications" and REMOVE "Synaptiks Touchpad Manager" from the list. Now Ubuntu's default Mouse Settings application works perfectly, and saves settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.