Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Lubuntu 11.04 and I installed Dropbox.

Every time I click on the tray icon, Dropbox opens Chrome to show my files.

How to change this behaviour? It would be nice to open my files from the tray with the regular file manager (PCManFM).

share|improve this question
    
Not sure if Ask Ubuntu is the best place to ask support for Dropbox - use their forums instead! –  papukaija Jun 25 '11 at 17:57
    
Isn't there an option when you rightclick: "Open Dropbox Folder" –  Syzygy Jun 25 '11 at 18:25
    
@Syzygy - "Open Dropbox Folder" opens the dropbox folder in Chromium. –  Shauna Sep 12 '11 at 18:49
3  
@Papukaija - Asking about Dropbox here isn't really any different than asking about PHP, Chrome, PyQT, VLC, or any other application (all of which have been asked about; for that matter, there's a Dropbox tag). Also, the question refers to Dropbox's behavior as it relates to Ubuntu with LXDE. –  Shauna Sep 12 '11 at 18:50
add comment

3 Answers

up vote 13 down vote accepted
  1. Install libfile-mimeinfo-perl from the repository
  2. Run (in terminal) mimeopen -d ~/Desktop (any folder can be used)
  3. mimeopen should prompt you to pick something to open it with. For me, PCManFM was the first option. Select the option that lists PCManFM.
  4. Open Dropbox from the system tray. It should now open in PCManFM.
share|improve this answer
    
Shauna - excellent answer. This one always has always puzzled me. Well done :) –  fossfreedom Sep 12 '11 at 19:15
    
Thank you! Finally it works. –  giowck Sep 13 '11 at 9:07
    
Glad I could help. :) I was having the same issue. I finally got annoyed enough to do some digging and experimenting. –  Shauna Sep 13 '11 at 13:58
add comment

I noticed that it works as well this way. This goes only for Firefox users.

  1. Install Firefox
  2. Click on the LXDE Menu Button down left in the screen --> Preferences --> Default Programs
  3. Change the default browser from Chromium to Firefox
  4. Open the Dropbox folder from the system tray. It should now open in PCManFM
share|improve this answer
add comment

I'm running KUbuntu, and for me the answer was to start System center, choose Default applications and File manager. There the default behaviour was to run mount. Not usfull to me. Changed it to Dolphin, and now it works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.