Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.04 under VMWare Fusion on my macbook pro. The first time I logged in, there was a message, something like "Unable to run Unity because your hardware is not supported, Ubuntu will now switch to the classic interface" (Not exact message)

And then (and every time I log in) Ubuntu starts with a version 10 like interface and after sometime (~20 sec) switches to a real "classic interface"

This is when I log in: Login

Immediately after I log in:

Immediately after log in

And in "sometime" (~20 to 30 sec):

(I did have the time to open the home folder, but I had to do it quickly)

In Sometime

  1. Is this normal?
  2. When Ubuntu says "Classic" interface, is this what it means?
  3. I understand there may be special h/w requirements for Unity, but the version 10 desktop should be the fallback right?
  4. Should I do some additional configurations somewhere?

(I have Ubuntu 10 on VMWare and it does work with the default desktop interface, albeit with the "No Effects" option)

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Even in the latest version update for VMWare Fusion 3.1.3 for Mac they claim to support Ubuntu up to version 10.04. only. There was some improvement in 3D support but this may only be true for Windows or Mac OS.

See also this question.

If you need to run Ubuntu 11.04 with Unity supported you may want to try out Virtual Box.

In case the theme is not set properly run the following line in a terminal in the guest Ubuntu:

 sleep 5; ps -aef | grep gnome-settings-daemon | grep -v grep | awk '{ print $2 }' | xargs kill -9; sleep 2; gnome-settings-daemon; killall nautilus
share|improve this answer
    
Did try VirtualBox. I get a similar problem. The new Ubuntu interface opens, but with the old "classic" icons: imgur.com/hM1T9 –  Nivas Jun 19 '11 at 16:15
    
This is bug #574296 see edit for workaround. –  Takkat Jun 19 '11 at 17:20

Your second image is the normal "Classic" mode. Apparently your gnome-settings-daemon dies after 20 to 30 seconds, so you are left with the ugly default theme. You can hit Alt+F2 and enter gnome-settings-daemon to start it again. And/or look in the .xsession-errors file in your home directory to find why gnome-settings-daemon crashes.

share|improve this answer
    
Alt+F2 corresponds to some specific command? Nothing happens when I hit that, is there any alternative? –  Nivas Jun 19 '11 at 16:12
2  
Alt+F2 should open a "run program" dialog. You can also open a terminal, it should be in the last item of the Applications menu. –  elmicha Jun 19 '11 at 16:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.