Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run Nautilus with sudo, gksudo or Alt+F2, I get this error message:

Initializing nautilus-gdu extension

** (nautilus:2352): WARNING **: Failed to get the current CK session: GDBus.Error:org.freedesktop.ConsoleKit.Manager.GeneralError: Unable to lookup session information for process '2352'

(nautilus:2352): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

** (nautilus:2352): CRITICAL **: nautilus_directory_file_monitor_add: assertion `NAUTILUS_IS_DIRECTORY (directory)' failed

(nautilus:2352): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(nautilus:2352): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(nautilus:2352): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(nautilus:2352): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

** (nautilus:2352): CRITICAL **: nautilus_directory_get_uri: assertion `NAUTILUS_IS_DIRECTORY (directory)' failed

Any idea why?

share|improve this question

closed as off topic by Bruno Pereira Mar 8 '12 at 23:49

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Is everything up to date? Try reinstalling gnome-disk-utility. –  nickguletskii Jun 18 '11 at 20:46
    
why disk utility?... i reinstall anyway and still same problem. –  meanie guthernhelf Jun 18 '11 at 22:00
    
Because nautilus-gdu stands for nautilus-gnomediskutility. –  nickguletskii Jun 19 '11 at 8:52
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions here. –  Bruno Pereira Mar 8 '12 at 23:49

2 Answers 2

Even if you fix this, there remains a problem with calling nautilus in sudo/gksudo/Open with administrative privileges:

Nautilus will remain in memory even when you close the root window, regardless what command-line options it gets, there is a --no-daemon or --no-fork option missing ever since.

I'd recommend using a different file-manager for root tasks, thunar from xfce for example.

share|improve this answer

Try installing gnome-user-share and see if that helps.

If Nautilus still doesn't start try this solution:

  1. Open a terminal (in Unity or Gnome)
  2. Then type sudo mkdir /usr/share/nautilus-scripts
  3. Enter your password and then hit Enter
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.