Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

wpa_supplicant seems to somehow be auto started at boot.

# ps auxwww |grep wpa
root       915  0.0  0.0  28824  1232 ?        S    17:36   0:00 /sbin/wpa_supplicant -u -s

How do I disable this service, prevent it from auto starting ?

share|improve this question
up vote 11 down vote accepted

Should be enough to remove the file

/usr/share/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service

Move it somewhere so you can restore it, rather than immediately delete it. ;-)

share|improve this answer
    
For Ubuntu 13.04, I have to move the file fi.w1.wpa_supplicant1.service – Jaime M. Dec 7 '13 at 18:43
    
Seems to still be the case for Ubuntu 15.10, which uses systemd. wpa_supplicant is started from dbus, not from init scripts directly: systemctl status wpa_supplicant.service shows it's running, but not auto-started by systemd directly. (So disabling for future boots isn't possible with systemctl). Also, dpkg-divert will keep it disabled across package upgrades. – Peter Cordes Dec 12 '15 at 2:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.