Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I tell a start up program to start minimized?

I am using Unity and I want Gnote to start minimized. When I start it now its search dialog is shown.

If it matters I am not using the standard setup because I have set Gnote to autostart and I have put Gnote in the panel by doing the following (which I learned from another question):

cd .config/autostart/
cp gnote.desktop gnote.desktop.old
cp /usr/share/applications/gnote.desktop ./
gsettings set com.canonical.Unity.Panel systray-whitelist "$(gsettings get com.canonical.Unity.Panel systray-whitelist | sed -e "s/]$/, 'gnote']/")

Two screenshots to illustrate.

What I want: Gnote starts minimized

What I get now: Gnote starts with search dialog open

share|improve this question

marked as duplicate by Jorge Castro, fossfreedom Dec 19 '12 at 9:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

UPDATE: I did some looking around and it looks like why it wont minimize to the tray is because it starts before the tray does, so there is no tray for it to minimize to. So I made a script that delays the start of Gnote so the tray has time to start first. sleep 5 && gnote -systray Just put that line is a script file and tell autostart to run that file. "5" is 5 seconds, so you can change it depending on what you need.

Original Post: This is how I got Gnote to start minimized on Fedora. I put a Gnote entry in the autostart and then added --start-minimized so it looked like this:

gnote --start-minimized

but it didn't work. I was confused because it worked when I put that command in the terminal and it worked, but not when I put it in autostart. So I found two other commands to try -min and -systray. -min did the same thing as --start-minimized (worked in the terminal but not in autostart) but then I tryed -systray and it worked! so I put this in autostart and it worked:

gnote -systray

The reason I posted the other two commands is because I am not sure which one works in Unity or Ubuntu.

By the way, I got the minimize commands from here: How do I tell a start up program to start minimized?

share|improve this answer
    
Neither command works nor can I find documentation for them. Do they really exist? –  N.N. Oct 19 '11 at 6:19
    
I'm using Unity (11.10). Even if I try the commands manually (when everything should be started) they won't work. –  N.N. Oct 21 '11 at 7:17
    
Well I have been trying this stuff on Fedora. I will go try to get it working on Ubuntu. Are you sure your using Gnote and not Tomboy? –  DanielTA Oct 21 '11 at 18:51
    
I'm sure. I'm using Gnote 0.7.5. –  N.N. Oct 27 '11 at 13:41
    
For me gnote -systray worked - after enabling 'Use Status Icon' in Gnote-Preferences -> General –  Thomas G. May 27 '12 at 14:38
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.