Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

From yesterday my update manager gives me this message:

Your current Hardware Enablement Stack (HWE) is going out of support on 07/08/2014. After this date security updates for critical parts (kernel and graphics stack) of your system will no longer be available.

For more information, please see: http://wiki.ubuntu.com/1204_HWE_EOL

But when I try to upgrade the HWE with the command suggested by hwe-support-status --verbose that is

sudo apt-get install linux-generic-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty linux-image-generic-lts-trusty

I get dependency errors:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx-lts-trusty : Depends: libglapi-mesa-lts-trusty (= 10.1.3-0ubuntu0.1~precise1) but it is not going to be installed
 xserver-xorg-lts-trusty : Recommends: xserver-xorg-input-all-lts-trusty but it is not going to be installed
                           Recommends: xserver-xorg-video-all-lts-trusty but it is not going to be installed
                           Recommends: x11-xserver-utils-lts-trusty but it is not going to be installed
                           Conflicts: libglapi-mesa:i386 (>= 0~)
E: Unable to correct problems, you have held broken packages.

How can I solve this?

I'm running Ubuntu 12.04.4 LTS 64 bit with kernel 3.5.0-53-generic.

share|improve this question
1  
There is a bug discussing this issue but as yet I haven't found a solution. –  Dogsbody Jul 10 at 18:47
    
I don't have enough points to comment so I must answer. Dogsbody's answer didn't work for me. ECII's one did (I tried the amd64 version). –  pmontrasio Jul 12 at 6:48
    
Just an FYI: I have a similar but slightly different issue where there are no packages recommended. –  Paul Jul 14 at 2:18
    
Please take note that different users seem to be reporting different things on HWE upgrade problems/solutions. See hwe-support-status does not tell me how to upgrade to 12.04.5, Hardware Enablement Stack (HWE) out of support, bug #1341324‌​, and bug #1341320‌​. –  Paul Jul 16 at 19:50

2 Answers 2

I had the same problem, this is what worked for me

Command:

For amd64:

sudo apt-get install -V libglapi-mesa-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty xserver-xorg-input-all-lts-trusty xserver-xorg-video-all-lts-trusty libgl1-mesa-dri-lts-trusty x11-xserver-utils-lts-trusty libglapi-mesa-lts-trusty:i386 libgl1-mesa-dri-lts-trusty:i386 libgl1-mesa-glx-lts-trusty:i386 libgles2-mesa-lts-trusty libglapi-mesa-lts-trusty mesa-vdpau-drivers-lts-trusty

For i386:

sudo apt-get install -V libglapi-mesa-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty xserver-xorg-input-all-lts-trusty xserver-xorg-video-all-lts-trusty libgl1-mesa-dri-lts-trusty x11-xserver-utils-lts-trusty mesa-vdpau-drivers-lts-trusty libgles2-mesa-lts-trusty libglapi-mesa-lts-trusty
share|improve this answer
    
There is an extra space in the name of package xserver-xorg-lts-trusty at the end of first line of `amd64`` –  Red Jul 11 at 13:04
2  
I don't know why this was voted down, it fixed the problem for me... –  Maidomax Jul 16 at 7:09
    
Using your command (64bit version) broke other packages dependencies for me.. I solve by fresh installing the 14.04 LTS –  Red Jul 29 at 10:16

Manually installing xserver-xorg-lts-precise first will make sure you have all the dependencies you need. Then install the packages defined by hwe-support-status.

For you this means running the two commands...

sudo apt-get install xserver-xorg-lts-precise
hwe-support-status --verbose
sudo apt-get install linux-generic-lts-trusty xserver-xorg-lts-trusty libgl1-mesa-glx-lts-trusty linux-image-generic-lts-trusty

This issue is discussed in bug #1328264 I just hadn't read it properly :-)

share|improve this answer
2  
Installing xserver-xorg-lts-trusty installed the other packages for me. –  metasequoia Jul 14 at 23:03
    
Yes, different systems will have different packages. They should all resolve dependencies correctly though :-/ –  Dogsbody Jul 15 at 8:40

protected by Community Jul 15 at 7:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.