Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, for some reason, I'm not allowed to prefix my post with the word "Hey"? Strange. Anyway:

I just got a new headset, and to my great surprise, ALSA doesn't even believe that a line-in exists. alsamixer/aplay -L/arecord -l list no capture devices. Audio out has worked wonderfully (over HDMI) since I built the machine, but no other output ports have ever worked (tested on Linux only). Here's some useful stuff, I think:

AlsaMixer lists a total of four playback devices (S/PDIF, S/PDIF 1, S/PDIF 2, S/PDIF 3) and no capture devices. I've never used AlsaMixer before, but it appears that something is wrong (shouldn't there be activity if something is playing?). Here's a screenshot, taken while playing music (again, I have no problem hearing the playback) (Ubuntu's Sound Preferences panel tells me that mocp is using an ALSA plug-in.):

http://imgur.com/VRMUj.png

"All" lists these four devices, and "Capture" lists nothing at all ("This sound device does not have any capture controls.").

Ubuntu's Sound Preferences panel lists no devices in the "Input" tab. The "Output" tab lists one "GF110 High Definition Audio Controller" with one "Digital Stereo (HDMI) Output".

This output appears to be fairly widely requested:

$ arecord -l
**** List of CAPTURE Hardware Devices ****

$ aplay -L
default
    Playback/recording through the PulseAudio sound server
pulse
    Playback/recording through the PulseAudio sound server
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=2
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    HDMI Audio Output
dmix:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample mixing device
dmix:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct sample mixing device
dmix:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct sample mixing device
dmix:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Direct sample mixing device
dsnoop:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Direct sample snooping device
hw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=7
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=8
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=9
    HDA NVidia, HDMI 0
    Hardware device with all software conversions

And here's my alsa-base configuration (completely Ubuntu stock):

$ cat /etc/modprobe.d/alsa-base.conf 
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

And some more output that I've seen requested in my recent Googling:

$ cat /proc/asound/card0/codec* | grep Codec
Codec: Nvidia GPU 18 HDMI/DP
Codec: Nvidia GPU 18 HDMI/DP
Codec: Nvidia GPU 18 HDMI/DP
Codec: Nvidia GPU 18 HDMI/DP

So, is there anyone with answers?

More output available upon request. My version of Ubuntu is 11.04 dist-upgraded from 10.10, but since this is a problem in the core packages and has existed for me since 10.04, I'm fairly sure this isn't a problem specific to a particular Ubuntu variant or version.

share|improve this question
    
What other "output ports" do you have? What audio devices are you running? Assuming you new headset has a mic, does it connect through USB or plug into a 1/8" jack? Also, alsamixer will only show the level setting of the controls, not the actual volume of the thing being played. –  jwernerny Jun 22 '11 at 15:14
    
I'm using HDMI to output to a monitor, and from either there or the box, my microphone is connected via 1/8" TRS. Since my original posting, I've found that both Windows and Linux simply don't see a capture device, so it's probably hardware. I'm probably going to add a low-end sound card, so that at least I have a line-in somewhere. –  RDE Aug 28 '11 at 18:38
add comment

1 Answer

It looks like you want to capture through the HDMI audio port on the graphics card. This is not possible - the HDMI ports on graphics cards have no capture functionality. You need to add a sound card to your system.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.