Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu 11.04 and I have an ASRock H67M-ITX/HT motherboard which is the Intel Sandy Bridge architecture.

I can't get sound to play through my TV on the HDMI interface. I have plugged in headphones and they work. I have also tried changing the device in sound preferences to the HDMI options provided

  • Digital Stereo (HDMI) Output
  • Digital Stereo (HDMI) Output + Analog Stereo Input
  • Digital Stereo Duplex (IEC958)
  • Digital Stereo (IEC958) Output + Analog Stereo Input

When I run the following command it plays sound fine.

aplay -D plughw:0,7 /usr/share/sounds/alsa/Front_Center.wav
share|improve this question
For the specific sound problem the answer here might help you with the HDMI sound:… Same procedure for having the sound through HDMI – Luis Alvarado Feb 15 '12 at 16:45
Do you still experience this problem? – Philipp Wendler Aug 10 '12 at 10:24

I remember logging in and logging out after plugging in the HDMI device and changing the sound settings to HDMI Output seemed to help in my case.

Additionally, running 'alsamixer' in terminal seemed to have made a difference before.

share|improve this answer
I've given that a try but it still doesn't work. When I run alsamixer I can set all of the volume controls to 100% except the S/PDIF ones. I can't move them from 0%. I thought S/PDIF was optical audio so i'm not sure if it makes a difference. – Alex Jun 18 '11 at 13:47

I seem to have a similar problem. Audio plays fine in flash (e.g. youtube) and in VLC when I specifically select ALSA audio output and select the correct device (hw:0,7 for me too), it appears that by default the system isn't using these settings.

I'll keep looking for a way of forcing the system to use these setting, but in the mean time hope you find the above vlc tip useful?

share|improve this answer
I ended up using windows... – Alex Jul 9 '11 at 16:09
@Alex can't say a blame you I'm getting rather bored of this too. – Wilfred Knievel Jul 9 '11 at 17:15
Lol, It worked first time and i've never had a problem :) – Alex Jul 10 '11 at 4:16

I see that you tried selecting the correct options in the "Hardware" tab of Volume Preferences, but a couple times I've seen systems where you need to also choose the correct hardware in the "Output" tab. Could this help?

share|improve this answer

Open the Terminal and run alsamixer by typing alsamixer and hitting Enter.

Use the arrow keys to go across to S/PDIF 1 and press M to unmute it. Press Esc to exit.

share|improve this answer

I got this working by opening "Sound Preferences" > "Hardware" then selecting "Digital Stereo (HDMI)" under "Settings for the selected device".

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.