Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I want to print something, I don't get the option to print on both sides of a paper although my printer supports this feature. How can I fix this? Do I have to download a proprietary driver?

My printer is a HP LaserJet p2015n.

share|improve this question

4 Answers 4

In addition to lamcro and wdypdx22's answer (check that the hplip package is installed) you need to make sure your printer is set to using the right driver. In System->Administration->Printers you can select the printer:

alt text

Right click on your printer and select properties, then click on the Button next to Make and Model that is labeled "Change", then the system will go looking for a driver:

alt text

Since you have it installed this won't take long (it can fetch updated ones from openprinting.org so there's never a need to manually install drivers). After the search it will give you an option to use the driver, select the one with (HPIJS). Now the printer options should be available in the "Printer Options" section of the last screenshot.

As a bonus, HP provides a native tool for Linux users that provides even more features than the bundled generic tool. It's called the hplip toolbox, you can install it by installing the hplip-gui package or just search for it in the Software Center.

alt text

This is the tool I prefer to use to manager my hp printers. There is a wishlist request bug asking that when anyone with an hp printer plugs in it just installs all this automagically, which would be pretty great.

share|improve this answer
    
Anything for SCX 3200 Series? –  BigSack Aug 9 '12 at 12:29

In the output of lpoptions -l, you should see a line that says:

HPOption_Duplexer/Duplex Unit: True *False

You can change this to True via lpoptions -o HPOption_Duplexer=True, and then your print dialog should allow you to print double-sided.

If you don't even have the "HPOption_Duplexer" option (e.g., lpoptions -l | fgrep -c Duplexer prints 0), then:

  1. either you have the incorrect printer description file configured (the so-called PPD),
  2. or you didn't check the "Duplex printing" option in the printer capabilities section.

To solve 1., the quickest path is probably to re-install the printer and choose the correct make/model combination.

To address 2., just open System -> Administration -> Printers, right-click on your printer and choose "Properties", then click on "Installed options" in the left pane and finally check the "Duplex printing" box on the right.

share|improve this answer
    
Thank you very much Mr.Riccardo Murri, it's really very help full for linux user, because main problem for new user of linux is that they don't under stand it's functionalities. I was facing this issue since last two months, once again very very thank you. Sunil kumar. –  user12174 Mar 11 '11 at 7:11

Try getting the latest version of HP's Linux Printing drivers (HPLIP).
Not all functionality comes pre-installed on Ubuntu. I myself had to install it and it accessed a lot of additional functionality.

share|improve this answer

I found a lot of help here: http://www.linuxfoundation.org/collaborate/workgroups/openprinting

Here's a link to your model: http://www.openprinting.org/printer/HP/HP-LaserJet_P2015

The site helped a lot with printer issues I was having a while back.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.