Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This started with me adding a graphics card to my system. When I booted up, ubuntu complained that the graphics config had changed, and gave me a terminal session. I copied /etc/X11/xorg.conf.failsafe to xorg.conf, and that gave me the standard graphical login manager.

Nw, when I try to log in the screen goes blank for a second, then returns me to the login manager. It tells me when I give it a deliberately bad password, so I know I'm authenticating. When I go across to a virtual terminal, I find that nothing in my homedir has been modified, except for ~/.dmrc if I've tried a different login mode. rAs a result, my usual resort of consulting ~/.xsession-errors is unavailable.

Other accounts like "Guest Session" are able to log in without problems, just mine fails. I have tried moving my ~/.xsession and ~/.xsessionrc to ~/xsession{,.rc}.bak, no effect. I've looked at /var/log/{syslog,auth.log,kern.log,Xorg.0.log}, and nothing interesting appears there when I try to log in... I've tried all the suggestions in the following earlier questions:

Login returns to login screen Where should I look to diagnose login freezing? Can't log in to ubuntu 12.04

What else can I try to diagnose this?

I think for now, I am going to work from a different account, but that is going to be a bit of a hassle.

share|improve this question

1 Answer 1

The answer was to delete the ~/.Xauthority file, as in this case.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.