Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 14.04 on a Dell laptop with 1.7Ghz Pentium M and 1Gbyte memory. Graphics are Intel® 852GM/855GM x86/MMX/SSE2, OS type is 32bit. The whole system is VERY slow. When I launch the applications manager, for example, I need to wait in order to see the letters I typed appear! It is as if the CPU was overloaded and no memory available, but I only have Firefox running.

How can I make the system run smoother? It used to have Windows XP installed and it worked fine.

share|improve this question

closed as too broad by Braiam, guntbert, Eric Carvalho, bain, qbi Jul 12 at 13:47

There are either too many possible answers, or good answers would be too long for this format. Please add details to narrow the answer set or to isolate an issue that can be answered in a few paragraphs.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you determine if the system has correctly found your graphics cards? the output of glxinfo | grep render may be of some interest. –  Charles Green Jul 8 at 15:44
2  
The system you described is more suited for the likes of XP and Ubuntu 12.04. Just as you wouldn't install Windows 7/8 on it, you should apply the same principle to other operating systems. –  prusswan Jul 9 at 2:29
    
Don't forget to accept an answer at some point by clicking the tick below the arrows. –  Tim Jul 9 at 12:09
add comment

5 Answers 5

Because you only have 1GB of RAM! That isn't the only problem, but it is part of it. Simply, your computer can't handle the intensity of Unity's graphics.

Windows XP is not nearly as CPU / Graphically intensive as Unity, the default desktop of Ubuntu 11.04+. It is based on compiz and has all sorts of fancy graphics, such as the see through dash and the expanding launcher. I would advise installing Lubuntu or Xubuntu, or putting XFCE or LXDE on, and using that rather than unity.

I have both on 3 old XP computers, and they are running well (typed on a 2006 Lubuntu laptop with 683 MB of RAM).

"It is as if the CPU was overloaded and no memory available" - The CPU probably is overloaded / there probably isn't enough RAM available. Try installing and using midori - it is lighter, and is what I'm using at the moment.

share|improve this answer
2  
See also: askubuntu.com/questions/206407/… - This wiki as well... I will confirm on the issues with Unity - it is slow on a quad-core desktop, not just old XP boxes. Most other Desktop environments are faster. –  Wilf Jul 8 at 15:40
1  
Basically its slower on the most powerful machine I have available - Gnome 3 is faster on a Intel Atom netbook & i5 laptop. –  Wilf Jul 8 at 15:47
2  
I have 8 GB of RAM, Intel i7 3.4 GHz and I found Ubuntu 14.04 lagging(not as worse as OP) and the system even freezed several times that I had to hard reboot. I switched to Xubuntu and found it way faster. Not even a single problem till date. –  Sundeep Jul 9 at 9:31
1  
Also the gpu may not be supported –  Thorbjørn Ravn Andersen Jul 9 at 11:34
1  
Well that may be part of it, but I wouldn't recoment unity to anyone with less than 4 GB, as I said I get freezes with 32 GB of RAM. –  Tim Jul 9 at 13:39
show 3 more comments

Two things:

1) Ubuntu 14.04 uses Unity 3D, which is based on Compiz. The whole thing is rendered through hardware-accelerated OpenGL. This is fantastic if you have good drivers and a good video card, not so much if either is missing.

There is absolutely no need to switch distributions. Just install a lighter desktop environment, log out, and log back in to the new desktop. For ease of use the preferred one is usually Xfce.

2) Combination of the broken update-apt-xapian-index cron job, and broken process scheduling in the kernel. Long story short, you need to append 'noautogroup' to your boot options, otherwise process niceness will not work. So:

  1. elevate to root with sudo
  2. in /etc/default/grub, edit GRUB_CMDLINE_LINUX_DEFAULT to be "quiet splash noautogroup"
  3. run 'update-grub'
  4. reboot

This is safer than using the kernel.autogroup sysctl variable, which may panic some computers.

Anyway, contrary to what a lot of people say, Ubuntu runs fine with 1 GB of RAM if you don't use the bloated default desktop.

Edit: actually I filed a Launchpad bug about the second issue last year: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1219548

share|improve this answer
    
Please use the "kernel.sched_autogroup_enabled" with some caution - it prevents my system from booting (Ubuntu 14.04 3.13.0.30-generic, Dell 15r) –  Charles Green Jul 8 at 20:37
    
@CharlesGreen the better way to do this is to use the 'noautogroup' boot option. I will update my post to reflect that. –  DanL4096 Jul 8 at 22:18
    
I had tried the echo 0 > /proc/sys/kernel/sched_autogroup_enabled variant, but I'm not sure the I felt it had any real effect. I'll give the boot option a shot. –  Charles Green Jul 9 at 4:40
    
Well, it booted (I'm here!) I'll have to poke at the system for a bit to determine if I think it feels faster –  Charles Green Jul 9 at 4:48
    
@CharlesGreen it won't "feel faster." What it will do is not bog down when niced background tasks are using a lot of CPU time, because it will prioritize other things ahead of those tasks. Otherwise there will be no difference (including for non-niced CPU intensive tasks). That's why I recommended a lighter, non-compositing desktop. noautogroup just avoids buggy behavior under certain conditions; using Xfce or Openbox will reduce resource consumption overall. –  DanL4096 Jul 9 at 12:32
add comment

There's also gnome-session-flashback which should look familiar if you have used previous iterations of Ubuntu. Apart from having a similar look-and-feel, it is also less resource-intensive.

share|improve this answer
    
Good suggestion. Last I used it though the Flashback panel (i.e. updated version of the old GNOME panel) had some performance issues though - it would hang and hog CPU when mousing over the "Office" menu, for some reason. –  DanL4096 Jul 9 at 12:34
add comment

You are extremely likely to have 2 relevant bottlenecks:

  • the low amount of RAM available to the system, which in some cases is even less then the nominal value, for example if your GPU is stealing some RAM from the system the total amount available to the system is obiviously 1Gb - WhatTheGPUIsUsing
  • the slow HDD. Tipically old notebooks have a 5400rpm disk, this is probably a really small figure for todays standards, there isn't a good troughtput that the OS can use.

The first consequence is that you have low RAM and not even the SWAP does any good because of the slow HDD.

Basically when you have a low amount of RAM the system uses the SWAP, a partition on your HDD, to store temporary files just like you do with your RAM in the first place, this allows the OS to get more temporary storage and "fix" things when there isn't a good amount of RAM available.

Unless you have deactivated or removed the swap partition, the swap is there and it's working against your timings, but you can't really do too much because even using a swap on a slow HDD is better then having your OS or your applications terminated because of the memory that is not there.

So you should just keep things as they are now, you can maybe do 2 things:

  • try another distribution like Archlinux, which is tipically faster and lighter but requires some tuning and you need to read some wiki articles and manuals to know what you are doing
  • try to boot into console without a GUI, if you can live with just the console your performane will benefit from that, obiviously it depends on what you have to do, if you have to code and write documents or check emails, you can do it with a terminal, if you like to browse the web, well you can do that too but it's certainly not up to what you get with firefox under an X11 session.
share|improve this answer
2  
People could probably write books about swap space. Personally I think modern OSes should have better ways of paging out dirty memory than the hard disk, which is ~6 orders of magnitude slower than main RAM - and also presents a security issue since decrypted stuff can get swapped out. Re Arch Linux and living on the console, again I don't see the point; one can always install a less elephantine desktop than Unity. –  DanL4096 Jul 9 at 1:39
    
@DanL4096 I was suggesting the console-approach because with that you remove the GUI from the equation completely, it also helps to free some more RAM sometimes. Unity is elephantine but X11/Xorg is no small software either and sometimes the drivers don't even help that much to speed things up. –  user3784961 Jul 9 at 1:50
    
The problem there is that a great number of very useful things can only be done from a graphical desktop, or would require a great deal of knowledge to do from the CLI... Also, Xorg by itself is in fact quite small. Xorg memory usage is partly a function of the applications running on top of it (and also shared video memory, etc.) Xorg, xterms, and most anything based on Xlib will run fine on a Pentium II - it's when you start dragging in heavy GTK+ applications that the troubles begin. –  DanL4096 Jul 9 at 2:29
    
I find in my laptop that changing the default disk scheduler to cfq made a huge difference in my perception of how well the computer runs. I believe it is actually a little slower, but it responds even during heavy disk operation (i have one of those 5400 rmp disks) –  Charles Green Jul 9 at 4:50
    
@CharlesGreen might be more to do with your hardware, or perhaps quirks of your typical usage patterns. I've never found CFQ much different from Deadline on desktop loads. The noautogroup thing makes a difference for intensive background tasks; but that's because it's not an optimization/tweak, it's a workaround for a bug (or something that ought to be considered a bug at least). –  DanL4096 Jul 9 at 12:27
show 2 more comments

Have you checked your swap file in System Monitor/Resources - though it was working OK in 13.10 - it has not been activated when I upgraded to 14.04 on my laptop.

share|improve this answer
2  
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Elder Geek Jul 9 at 15:06
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.