Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The issue is similar to this: Thinkpad middle button scrolling

But here, I have an average computer. Basically, when I press the middle button in Windows and move the cursor a little from the starting position the page starts scrolling which is very convenient because I don't have to scroll the wheel madly.

I looked at the second solution to the question mentioned earlier; the button drop down menu is greyed out.

Thanks in advance.

share|improve this question
add comment

2 Answers 2

You can enable it during the current session using the xinput command. First of all, determine the ID of the device you want by running the xinput list command. The output should look something like the following:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=8    [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=9    [slave  pointer  (2)]
⎜   ↳ Lite-On Technology Corp. ThinkPad USB Keyboard with TrackPoint    id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Logitech Logitech USB Headset             id=10   [slave  keyboard (3)]
    ↳ Lite-On Technology Corp. ThinkPad USB Keyboard with TrackPoint    id=11   [slave  keyboard (3)]

Note the ID associated with the device you want to enable mouse wheel emulation for, and then run the following two commands:

xinput set-int-prop $ID "Evdev Wheel Emulation" 8 1
xinput set-int-prop $ID "Evdev Wheel Emulation Button" 8 2

The first command enables mouse wheel emulation, while the second sets it to activate when the middle (second) button is held. You can disable wheel emulation by running:

xinput set-int-prop $ID "Evdev Wheel Emulation" 8 0
share|improve this answer
    
Eeeh, good for an ugly workaround... But I am looking for a more elegant solution because doing that isn't very convenient. –  nickguletskii Jun 18 '11 at 16:32
1  
Well, you said that the gpointing-device-settings solution from the other question didn't help. If this suggestion works for you but doesn't work in gpointing-device-settings, then the bug is in that app (it is basically just a front end for twiddling xinput properties). You could follow that up with a bug report. –  James Henstridge Jun 18 '11 at 16:36
    
Also, the first answer in that question (an xorg.conf fragment) should do the trick (you should only need to set the EmulateWheel and EmulateWheelButton options though). –  James Henstridge Jun 18 '11 at 16:39
    
@James Henstridge I have just tried this, unfortunately this didn't work. xinput set-int-prop $ID "Evdev Wheel Emulation" 8 1 Invalid format 1 So I assumed that I had to replace $ID with the ID of the pointing device, I did. Returned nothing. Repeated with the second one. Doesn't do anything. –  nickguletskii Jun 18 '11 at 17:02
1  
You should be replacing $ID with the ID of the device you want to modify (for the set of devices on my system, 8 or 12 represent my mouse devices). If you got the error "Invalid format 1", then you must have missed an argument and it was treating the 1 as the 3rd argument to set-int-prop instead of the 4th. –  James Henstridge Jun 19 '11 at 2:39
show 2 more comments

I'm wondering if you are talking about 'Autoscrolling' in Firefox here? I don't know how to get the feature system-wide, but if you are looking to enable middle click scrolling in Firefox, go to Edit/Preferences/Advanced/General and click Use autoscrolling. (Note that if you middle-click while hovering on a link, you will open that link in a new tab).

If this is what you want, you should update the question to mention Firefox. If not, sorry I couldn't help. enable autoscrolling

share|improve this answer
    
I don't use Firefox but this is exactly what I want. –  nickguletskii Jun 18 '11 at 19:33
    
The Autoscroll extension works for Chrome/Chromium. It's here: chrome.google.com/webstore/detail/… –  Tom Brossman Jun 19 '11 at 10:28
    
put that in the answer and I will upvote. I am afraid I can't accept this as the needed answer because it only solves this for particular applications. –  nickguletskii Jun 19 '11 at 10:55
    
it also doesn't do it as smooth as I would expect it to. –  nickguletskii Jun 19 '11 at 11:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.