Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Wubi on my Windows 7 64bit machine yesterday, and since then, the windows partition is ridiculously slow. As in, takes an hour to boot. Once it boots, it takes ten minutes to log in. Rebooting takes an hour or so to shut down.

The C: drive is an SSD, but it didn't have enough space for Wubi, so I put Wubi on the other 500gb regular spinning-disk secondary partition. I don't know if that matters.

I did see this: http://ubuntuforums.org/archive/index.php/t-373876.html

but I'm not sure that's a relevant link.

What can I do to fix this problem? If the best solution is to install Ubuntu in a second partition (and by 'best' I mean "able to work again as quickly as possible with a minimum of debugging time, this has cut my productivity to nothing"), then how can I undo this?

EDIT: I believe I'm experiencing issues similar to what's described here:

http://www.tomshardware.com/forum/250282-32-major-problems-formatting-partitioning-intel-windows-install

I tried to reinstall Windows this evening, and it just failed miserably on the drive. So badly, in fact, that it got to 29% of files copied, and then just crapped out. That means that something on the drive is dead, especially since the same copy of Windows is now installing without any apparent issues on the spinning disk. Looks like the timing of this failure just happened to coincide with the Wubi installation.

share|improve this question
    
That Forum thread is inappropriate, since it deals with dual boot not a Wubi install. –  Oxwivi Jun 17 '11 at 18:45
    
OK then. If there's another solution, then I'll be happy to try it. –  mmr Jun 17 '11 at 18:52
    
What kind of SSD do you have? –  Lekensteyn Jun 17 '11 at 20:21
    
Intel 320M. But ubuntu isn't on the SSD, Windows is. –  mmr Jun 17 '11 at 21:48
    
@mmr can you look on your windows 7 computer if you got less than 20 % free hard disk space this can make windows 7 extremely slow. –  Rens Jun 19 '11 at 7:28
show 2 more comments

4 Answers

up vote 2 down vote accepted

This turned out to be a hard drive failure in the making; complete reinstallation of windows caused a subsequent hardware failure. Turns out that SSDs aren't the magic bullet against hardware failure after all.

share|improve this answer
    
Flash-based SSD, or RAM-based SSD? –  Oxwivi Aug 15 '11 at 16:43
    
I think it's drive specific, given this information: qdms.intel.com/dm/d.aspx/7446CFE4-2465-4D6A-83CB-3E52EFAA5AC9/… –  mmr Aug 15 '11 at 18:43
add comment

There is very low possibility a Wubi install could slow down your Windows install, especially when it is on a secondary drive. My first guess was that you may have somehow installed wubi on the Windows partition, filling it up and slowing Windows down.

Since this is not the case, try the following :

  • Uninstall wubi. Just rerun the wubi setup and it would allow you an option of uninstalling. You can also uninstall using the Add Remove Software option. Since you only installed yesterday, you don't have anything to worry about. You could always reinstall. This way you'd know for sure if wubi was the culprit
  • Check for viruses, and other malware. Run a complete scan.
  • Run msconfig and check the Startup tab. It might give you hints about some rogue applications on startup.
  • Did you install/uninstall any drivers recently ? Windows often has issues booting up after such things. And since you only talk about startup time, I assume its the time you've to see the Starting Windows screen.

Hope it resolves your issue.

share|improve this answer
    
I'm not so sure about the "no way" claim-- if ubuntu is messing with the boot loader (which it must), then if the boot loader is misconfigured for windows, then it's possible that the drive is being accessed incorrectly. Especially if the bootloader is on the 100 mb recovery partition, which is what I was doing: sevenforums.com/installation-setup/… If wubi managed to mess with that somehow, that could easily explain the behavior I saw. I have no desire to try to replicate the issue, because I have work to do. –  mmr Jun 18 '11 at 19:59
    
You never told what stage of the boot was slowed down. I assumed (as is usually the case) that it was the Windows loading screen. I don't think the 100mb boot partition has anything to do with at that time of the boot stage. –  Capt.Nemo Jun 19 '11 at 1:05
    
No, EVERYTHING was slow. An hour to boot, another half hour to log in, five minutes to open the start window, etc. During reinstallation, it became readily apparent that the 100 mb recovery partition had been completely munged, and that another windows installation was only possible through repartitioning the drive and reformatting. Since I hadn't done anything else on this machine except the Wubi installation, that became the obvious culprit, though I suppose that the drive itself could have had some failure that it's since recovered from after reinstallation. –  mmr Jun 19 '11 at 1:42
    
One other potential culprit was windows resetting to PIO mode instead of UDMA, but the BIOS was reporting that the drive was still accessible in PIO mode. –  mmr Jun 19 '11 at 1:43
add comment

Try to disable antivirus software and firewall (better to so so offline), reboot and see if the slowdown improves.

share|improve this answer
add comment

The best option in this case is likely to, as you suggested, install Ubuntu in a separate partition. Installing Ubuntu via Wubi is an easy way to go, but it can gradually cause both operating systems to slow down through file fragmentation.

The Wubi install on your secondary drive is unlikely to slow anything down unless you have system or application files on it. And even so, it is not likely to cause a dramatic slow down as you describe. It is more likely that the cause lies somewhere else.

To summarize, it is best to install Ubuntu in a separate partition, but not doing so is unlikely to cause the slow down you are experiencing, especially since it is on a separate drive.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.