Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Everytime time I boot and login into my Xubuntu 14.10, Skype, Thunderbird and Firefox start up even though I closed them before I logged out and shut down. These programs are not in the list of autostart programs. So how can I reset the session?

share|improve this question

marked as duplicate by Jorge Castro, bain, karel, Wilf, Rinzwind Jul 9 at 15:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 1 down vote accepted

I had a similar problem in Xfce as well where goldendict kept opening on startup. In order to solve this, you go to session and startup on settings and go to the application autostart tab. Then go to add, and make the name and description whatever you would like. Under command put killall (program name). Add this for whatever programs you don't want on startup. Also, under general, you may want to uncheck the Automatically save session on logout. Under the session tab you may want to clear saved sessions.

share|improve this answer
    
The hint "Under the session tab you may want to clear saved sessions" did the trick! –  ubuplex Jul 8 at 10:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.