Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ubuntu logs me directly into my desktop, but is not showing the login screen. I have 14.04 LTS so I want to select KDE, but my system boots to the desktop directly. Any way to go to the login screen so that I can log in as usual?

share|improve this question
    
Would you mind accepting an answer; it helps keep the stack exchange clean –  Akiva Aug 5 at 21:48

3 Answers 3

Just go to System Settings -> User Accounts and disable automatic login.

enter image description here

That way, you will always be prompted for the password and it's in that login screen you can choose which environment to login to.

share|improve this answer
1  
Comic sans?! That better be cuz of "comic sans day", Parto :D –  Rinzwind Jul 8 at 12:25
1  
@Rinzwind That's not comic sans. It's called 'VeggieBurger' :-) –  Parto Jul 8 at 13:32
    
fine fine have an upvote then :D –  Rinzwind Jul 8 at 13:37
1  
@Rinzwind Wow, thanks alot. I appreciate. Oh, and the title bar, it says 'user accounts', that's Pseudo Saudo –  Parto Jul 8 at 13:40
    
Thanks a lot! Now i can select my environment although i had to erase my disk and reinstall everything because i deleted lightdm and installed kubuntu. No kdm was there. –  user300873 Jul 9 at 1:12

System Settings -> User Accounts -> slide the automatic login button to off

Alternativelly,

Open the command line / terminal (Ctrl+Alt+T)

Enter the following command

sudo nano /etc/lightdm/lightdm.conf

You should see in there something like

[SeatDefaults]
autologin-user=yourusername

where yourusername is your actual username. Remove autologin-user=yourusername, the whole line, but leave `[SeatDefaults].

*N.B: if you don't see those lines, I would recommend exiting without making any changes to the lightdm.conf file

share|improve this answer

Your system has been set to automatically log you in - this was a choice you probably made at install time. You can switch desktops by choosing logout (not shutdown or reboot) which will take you to the login screen where you can then choose a desktop.

Choosing a desktop is persistent - next time you reboot it will take you back to the desktop you have chosen.

To disable to automatic login, you can use the 'User Accounts' program -> open the dash and type user...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.