Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install the provider plugin for thunderbird, but it said my release was too old. I have the lastest release of thunderbird in the lucid archives.

share|improve this question
add comment

4 Answers

up vote 6 down vote accepted
+200

For Ubuntu 10.10+

Installing the necessary components is just a matter of running:

sudo apt-get install xul-ext-lightning xul-ext-gdata-provider

This will install the Lightning Calendar extension and the Google Calendar provider.

For Ubuntu 10.04

Unfortunately, Lightning is not available in the Ubuntu repositories for 10.04 LTS users. If you are running Ubuntu 10.04 LTS, you have 2 options:

  1. 32-bit users can install a version of Lightning compatible with Thunderbird 3.1 from https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/?page=1#version-1.0b2
  2. You can install the latest stable version of Thunderbird, following the instructions in How do I install the latest stable version of Thunderbird?. The thunderbird-stable PPA also has a compatible version of the Lightning extension for Ubuntu 10.04 LTS users.

I would strongly discourage disabling the addons compatibility checker, as advised in another answer. The check is there for a very good reason, and disabling it could make Thunderbird unusable.

share|improve this answer
    
Thanks, this solved my problem. –  txwikinger Nov 1 '10 at 14:47
add comment

I just tried it out, and you'll need

  1. Lightning
  2. Provider for Google Calendar

To disable compatibility checking for extensions, open Thunderbird's preferences, switch to the "Advanced" tab and in the "General" subtab, start the config editor. (source)

Where to find the Config Editor

Add a new boolean value via right click named

extensions.CompatibilityCheck.[VERSION]

set to false.

[VERSION] stands for your Thunderbird version, e.g. 3.1, if you're using 3.1 stable, 3.1a if you're using 3.1 alpha, or 3.1b if you're using 3.1 beta. (source)

Then you can just install your extensions.

Should the Config Editor be unavailable for any reason whatsoever, you can always manually edit ~/.mozilla-thunderbird/[somecharacters].default/prefs.js.

Add the following lines as necessary:

user_pref("extensions.checkCompatibility", false);
user_pref("extensions.checkCompatibility.3.0", false);
share|improve this answer
    
the default thunderbird does not seem to have this configuration option. –  txwikinger Aug 4 '10 at 18:00
    
Updated. The indicated button is unavailable? Version 3.0.6+build2+nobinonly-0ubuntu0.10.04.1 from lucid-updates shows me this button. Alternatively you edit ~/.mozilla-thunderbird/[somecharacters].default/prefs.js by hand. –  ParanoiaPuppy Aug 4 '10 at 19:24
add comment

You need the 'Lightning' extension for Thunderbird (http://www.mozilla.org/projects/calendar/) and the google provider plugin (https://addons.mozilla.org/en-US/thunderbird/addon/4631/).

You can then ask the creation of a new "network" calendar, and identify it using the "private URL" that Google Calendar gives you (in the calendar's preferences).

share|improve this answer
add comment

if you have a fairly new thunderbird + lightning combination (or the standalone calendar program sunbird) you can use caldev to have a two-way sync.

for a detailed explanation and howto you can read this blogpost by aaron toponce

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.