Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently added a partition to my computer with Ubuntu 14.04 LTS 64-bit.

It is Turbo-X dual-boot with Windows 7. The Ethernet works good in Windows but in Ubuntu does not work.

The wired connection is trying to connect to the switch all the time but it does not connect.

george@myia:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:90:f5:8c:2e:04
          inet6 addr: fe80::290:f5ff:fe8c:2e04/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:310 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4920 (4.9 KB)  TX bytes:56934 (56.9 KB)
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:410 errors:0 dropped:0 overruns:0 frame:0
          TX packets:410 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:33513 (33.5 KB)  TX bytes:33513 (33.5 KB)

wlan0     Link encap:Ethernet  HWaddr 00:1d:e0:84:b6:39  
          inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21d:e0ff:fe84:b639/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:254 errors:0 dropped:0 overruns:0 frame:0
          TX packets:318 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:45164 (45.1 KB)  TX bytes:38175 (38.1 KB)

george@myia:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             disconnected
  Default:           no
  HW Address:        00:90:F5:8C:2E:04

  Capabilities:
    Carrier Detect:  yes
    Speed:           1000 Mb/s

  Wired Properties
    Carrier:         on


- Device: wlan0  [MF60_B6EF5F] -------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwl4965
  State:             connected
  Default:           yes
  HW Address:        00:1D:E0:84:B6:39

  Capabilities:
    Speed:           54 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *MF60_B6EF5F:    Infra, 78:E8:B6:B6:EF:5F, Freq 2437 MHz, Rate 54 Mb/s, Strength 79 WPA

  IPv4 Settings:
    Address:         192.168.0.102
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             192.168.0.1

george@myia:~$ lspci -nn | grep Ethernet
07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 02)
share|improve this question
    
Please post the output of dmesg | grep eth0. And also please specify to which device the cable is plugged in (probably it's router; which model?). –  user300458 Jul 7 at 16:14
    
[ 4.504708] r8169 0000:07:00.0 eth0: RTL8168c/8111c at 0xffffc9000063c000, 00:90:f5:8c:2e:04, XID 1c4000c0 IRQ 46 [ 4.504713] r8169 0000:07:00.0 eth0: jumbo features [frames: 6128 bytes, tx checksumming: ko] [ 11.141537] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 24.793326] r8169 0000:07:00.0 eth0: link down [ 24.793364] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 24.793757] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 99.654444] r8169 0000:07:00.0 eth0: link up [ 99.654463] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready –  GeoMind Jul 7 at 18:36
    
@user300458 it is a TP-LINK switch –  GeoMind Jul 7 at 20:30
    
@GeoMind The output of dmesg | grep eth0 is very hard to read when posted as a comment, as line breaks are not preserved. I recommend adding it to your question itself, by editing. –  Eliah Kagan Jul 24 at 2:25

2 Answers 2

sudo dhclient -r and sudo dhclient eth0

share|improve this answer
    
it doesn't worked. Thanks. –  GeoMind Jul 7 at 18:30
    
Find your subnet and gateway, and a random free IP address. (get this from working windows box) Turn off your wireless and sudo ifconfig eth0 192.168.X.X netmask 255.255.255.X and then ping gateway –  meccooll Jul 7 at 20:36
    
it is a switcher. i connected it to my router and worked. i want to work for my TP-Link switch. –  GeoMind Jul 7 at 20:41
    
HUH? Not following your setup. So you just have 2PCs connected through a switch? If that's the case then you won't have DHCP server and have to configure the IP/subnet manually –  meccooll Jul 7 at 22:08

I had this very same issue.
Went into my bios and turned on the IOMMU option for my motherboard.
After that, Ubuntu saw the ethernet and worked properly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.