Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have set sysctl to disable ipv6:

vagrant@puppet:~$ cat /etc/sysctl.d/10-ipv6-disable.conf 
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Next I have rebooted and checked that ipv6 is disabled (1 = disabled):

vagrant@puppet:~$ cat /proc/sys/net/ipv6/conf/all/disable_ipv6
1

However, netstat shows that applications are still binding to ipv6 ports:

vagrant@puppet:~$ netstat -nalt
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN     
...
tcp        0      0 192.168.56.5:3389       192.168.56.1:32744      ESTABLISHED
tcp6       0      0 :::22                   :::*                    LISTEN     
tcp6       0      0 :::53378                :::*                    LISTEN     
tcp6       0      0 :::111                  :::*                    LISTEN

Any ideas?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

You are disabling IPv6 on network interfaces, but that doesn't mean that the system doesn't have IPv6. If you want a system without IPv6 then you have to disable the ipv6 kernel module.

The usual disclaimer applies: disabling IPv6 usually is a bad idea. Better to learn to work with it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.