Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello i try to disable the guest account in ubuntu 14.04 by typing these commands sudo gedit /etc/lightdm/lightdm.conf allow-guest=false

After re-staring ubuntu it boot up but dos not go to log-in screen just no signal appears on moniter. please please help me.

share|improve this question
I tryed these commands to disable user account: 1) sudo gedit /etc/lightdm/lightdm.conf 2) allow-guest=false – user258548 Jul 7 '14 at 4:00
If you press Ctrl+Alt+F1, does it bring you to a terminal login? – That Coder Guy Jul 7 '14 at 4:01
try ctrl+alt+f1 you can acess to tty1 ? – hwez Jul 7 '14 at 4:01
Yes i can access to tty1 now what to please help me any one – user258548 Jul 7 '14 at 4:15


$ sudo service lightdm restart

ctrl+alt+F7 or F8 if the lightdm still doesn't show up re install it

$ sudo apt-get autoremove lightdm
$ sudo apt-get install lightdm
sudo dpkg-reconfigure lightdm

ok ==> chose lightdm the

$ sudo apt-get update && sudo shutdown -r
share|improve this answer

I believe the problem is that you're missing one line in your code.


So how can you edit lightdm.conf again ?

Option #1: Command line has a wonderful text editor called nano. You can learn more about it later using man nano, but for now, log into tty1, like you already know, and do the following:

sudo nano /etc/lightdm/lightdm.conf

Add that [SeatDefaults] line and press Ctrl+O and it should ask you "Filename to write: /etc/lightdm/lightdm.conf ", so simply press enter. It should say [Wrote 2 lines]. To exit nano press Ctrl+X. *N.B.: Ctrl is symbolized as ^ in the command line, so you'll see that a lot, e.g. Ctrl+x = ^X.

Now you should have exited nano, and can reboot using

sudo shutdown -r now

Personally I prefer nano instead of gedit, but that's just a matter of taste and what works best for you.

Option #2: lightdm is supposed to be a light display manager, but if you don't mind using something else you can download gdm display manager which has it's own login screen (or greeter, in the jargon or linux world). Actually, this is the same path i took when trying to solve the same problem. So how do we get it?

apt-get install gdm

I don't exactly remember whether it should prompt you to set gdm as default display manager or not, but in case it doesnt, you can always do the following:

sudo dpkg-reconfigure gdm

Next you should see a prompt explaining what the display manager is, with thingy at the bottom. Press enter. Now you should see a screen with two choices lightdm and gdm, and using arrows highlight gdm, and press enter. Reboot using the same command as before.

Reboot with the prompt that i mentioned before.

So after you got to login screen and back to your desktop( oh and you can actually change desktop environments from login screen, too, just in case you might need that ) you can open gedit again and change that lightdm.conf file again, or you can live on with gdm. Your choicese. You can always get rid of either desktop manager by using apt-get remove command. For lightdm that would be

sudo apt-get remove lightdm.

BONUS: If you're like me, and mess with desktop environments every once in a while, you might wanna kill boredom while fixing your problem. moc player is command line music player (yup, that's right), which you can install using `sudo apt-get install moc And to run the actual player run mocp command. Also mc , aka midnight commander file manager is useful to have if you don't have access to graphical envirnoment. Again, sudo apt-get install mc is how you get this tool. And finally elinks or links internet browsers are nice to have in command line if you have messed up gui and need to look up some answers. Again, sudo apt-get install elinks, run elinks, and g to enter the address you need, like

Let me know if this helped a bit.

Some more info here:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.