Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two dilemma's here:

One is, I tried using iftop but it said I don't have permission to capture on that device (socket: operation not permitted) I can use ifconfig just fine.

Also, I installed NetHogs and tried to use it. But it came up with, you need to be root to run NetHogs.

I'm extremely new to ubuntu, anyone help?

share|improve this question
    
You can use sudo to run programs with elevated (root) privileges. Example sudo iftop –  Nischay Jul 5 at 20:30
    
iftop needs to be run as root as Nischay says, so sudo iftop it is. –  hatterman Jul 5 at 21:23

1 Answer 1

up vote 0 down vote accepted

use sudo or gksu

$ sudo nethogs

or

$ gksu nethogs
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.