Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been looking around for an answer to my problem but I can't find anything. My problem is that I recently bought a new computer, Lenovo G500, it has 2xUSB3 and 1xUSB2, Intel pentium I3 2.4 GHz x4 and 6 Gib memory, it came with windows 8 but I removed it and installed Ubuntu 14.04.

The problem is, if, lets say, I try to copy one folder/file (doesn't matter the size) from/to my hard drive from/to the usb device, I have a WD 1tb usb 3 external HD but it does it with usb pens or another HD I have, it will copy fine, with high speeds. However, if I was to start a second copy/transfer while the first one is still going it will make the copying speed for both actions almost come to a stand still and take several hours.

This is not the only problem, the other problem is that while the copying is going on if I open any windows or programs they will take a very long time (may be up to 1 min) to open/start.

If I open the system monitoring it tells me that only 10% (+ or -) CPU usage, so memory is not an issue.

Any ideas what could be going on?

Thank you very much in advance

share|improve this question

1 Answer 1

What worked for me on a laptop was to change the disk scheduler. This can be cone in three ways:

Test it by typing at the command line (ctrl+alt+t)

echo cfq | sudo tee /sys/block/sda/queue/scheduler

and replace "sda" with the device name of your devices. Do this for both of your disks. You can check what scheduler is in use by entering

cat /sys/block/sda/queue/scheduler

reboot to revert to standard if this does not work.

To make the changes permanent, place the command into /etc/rc.local or add a kernal option elevator=cfq

more information


Since I wrote this answer, I have changed my strategy. I now user the cfq disk scheduler, but have added the 'noautogroup' flag to my boot parameters.

share|improve this answer
    
Thank you, I will check it later (as I'm in a different computer right now) and get back to you with the outcome. –  user300695 Jul 7 at 6:25
    
Ok, I finally I had a small break from work and I managed to do this. Unfortunately it didn't work it tells me straight away:bash: /sys/block/sda/queue/scheduler: Permission denied, any suggestions what would that be? It doesn't even give me the chance to put my administrator password. –  user300695 Jul 11 at 9:32
    
Sorry - the command should be started with sudo--- sudo cat /sys/block/sda/queue/scheduler –  Charles Green Jul 11 at 13:14
    
Hi; the second command was fine, that one told me noop [deadline] cfq, is the first command you put in the orignial answer: sudo echo cfq > /sys/block/sda/queue/scheduler that tells me despite sudo: bash: /sys/block/sda/queue/scheduler: Permission denied –  user300695 Jul 12 at 14:35
    
Ah - I always have trouble with sudo and echo - what you can do instead is type sudo -i which will run sudo as a shell, then type echo cfq > /sys/block/sda/queue/scheduler within the shell to get the command to run. You will need to type exit to leave the shell, and exit again to close the terminal –  Charles Green Jul 12 at 14:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.