Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have setup my ubuntu box so I can use Windows remote desktop to log into it. I was trying to use the terminal and when I tried to type the cd command, it typed the c but the d key minimized the screen. Pressing d again brought the window back. Open more windows, same effect.

It appears that d is triggering the show desktop command. None of my alt, ctrl, or shift keys are pressed. When I do press alt key, it brings up the menu like I expect. When I press shift or caps, I can actually type a capital D. when capslock is on, and I press shift and d, it does the show desktop again.

One other note, my password has a lowercase d, so it types correctly until I get into the desktop. I'm using the Ubuntu classic desktop.

I'm new to ubuntu and linux, and I'm not the most familiar with the configuration settings. What could be causing this?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

If you have CompizConfig setting manager installed open the application and choose General, General option, key bindings and look what keybinding is assigned to "Show Desktop" and change it as you like.

share|improve this answer
add comment

I have put the following into /etc/profile to get around this problem with pressing the "d" key

gconftool-2 -s /apps/metacity/global_keybindings/show_desktop -t String "disabled"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.