Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Within a few days my broadband connection will be cut.Then the only way I can connect is to use a usb modem(Visiontek 82GH HSUPA).The problem is I cannot use the modem in an ordinary account and has to login using a root account to use it.So is there some way to use an ordinary account to use the modem.Using gksudo or sudo does'nt help.Please this is urgent.Thanks in advance.I am using Ubuntu 14.04. Please suggest some way to get temporary root rights or something else. For those who do'nt know how visiontek works,I will try to explain it the best I can. In windows Visiontek can be run by just inserting it and then installing a program.But in Linux its more complicated.You have to copy a folder from the modem to the usr folder.And in that you should first run the install script and dialup script both with root rights,all while inserting the modem.When I run the dialup script in an ordinary acount it says the usb modem is not ejected even when it is while in the root account it runs okay(You have to eject the modem before dialup for it to work.This will open the built-in memory card reader.)

share|improve this question
    
I hate to say it,but I think Ubuntu sucks for me. –  user249918 Jul 4 at 13:29
    
I say it not because I hate it but because I have'nt found a solution to any of my questions.If I did hate it I would have changed it a long time ago. –  user249918 Jul 4 at 13:30
    
If I do'nt get a solution today I am afraid I will have to change to Windows tomorrow.I am not really a fan of Windows but I cannot live without the net. –  user249918 Jul 4 at 13:36

1 Answer 1

I've found a solution for this.First plug the modem into any Windows device.(I used my friends.)Then copy the 'Linux_dialer' folder into a usb or some other place.Copy the folder into the usr folder in Linux using gksudo.Open a terminal and run sudo su.Change directory to the '/usr/Linux_dialer'.Run the command 'install' or 'dialup' after installing.(Sometimes you will have to type the full path.) I tried this only in Ubuntu 14.04.I don't know how to do it in other versions.Hope it helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.