Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seldom use the DVD drive and this a 5 year old laptop. Today I load the DVD and it just keeps spinning but nothing mounts. After it spins and stops I checked:

dmesg | grep sr0

[ 1.738204] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray [ 1.738551] sr 1:0:0:0: Attached scsi CD-ROM sr0

I tried to manually mount with

sudo mount /dev/sr0

sudo mount /dev/cdrom

Then I checked:

mount | grep "/dev/sr"

It shows nothing.

The DVD is good and readable on my Windows machine.

Any ideas on how I can get it working?

share|improve this question
Did you run mount /dev/sr0 /mnt/cdrom ? – Ruslan Gerasimov Jul 4 '14 at 5:25
Is it a DVD movie film or just data media? Are other disks mounted well in your system? – Ruslan Gerasimov Jul 4 '14 at 6:24
Its just data that I had backed up from the same laptop. I have just an internal HDD which is mounted and working. – eshwar Jul 4 '14 at 6:32
Commands that you mentioned "sudo mount /dev/sr0" do not seem good for me until they have a place where to mount to. So what about running mount /dev/sr0 /mnt/? – Ruslan Gerasimov Jul 4 '14 at 6:45
sudo mount /dev/sr0 /mnt/ returns mount: no medium found on /dev/sr0 – eshwar Jul 5 '14 at 3:52

I also couldn't mount movie DVDs, and was having this error:

~$ dmesg | grep sr0
VFS: busy inodes on changed media or resized disk sr0

The solution that worked for me was to edit /etc/fstab which I found in a mail-thread.

So, as described there, I edited the file, adding in the end the following line:

/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

and then I had to restart, since fstab is loaded on system start.

share|improve this answer

Did you get any message after mount /dev/sr0 or mount /dev/cdrom?

I got something like: mount: can't find /dev/sr0 in /etc/fstab or /etc/mtab

Here is a quick example on my Ubuntu 14.04 Desktop. I mount the DVD to /mnt

$ sudo mount /dev/cdrom /mnt/
mount: block device /dev/sr0 is write-protected, mounting read-only
$ cd /mnt/
$ ls
autorun.inf  casper  EFI      isolinux    pics  preseed             ubuntu
boot         dists   install  md5sum.txt  pool  README.diskdefines  wubi.exe'
share|improve this answer
Yes, I also got the same message and I have already tried to manually mount to mnt. But when I try that I get mount: no medium found on /dev/sr0 OR mount: /dev/sr0 already mounted or /mnt/ busy Mostly it is the first message. – eshwar Jul 4 '14 at 9:56
Can you try some other DVDs/CDs? Jsut want to make sure it's not a disk compatibility issue. – asdone Jul 4 '14 at 11:00
Same with every DVD that I try – eshwar Jul 5 '14 at 3:53
the mount points (/media/cdrom nodes must exist and an appropriate line in the fstab file otherwise the user cannot mount them – user3629249 Feb 25 '15 at 23:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.