Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question is an exact duplicate of:

I do understand that this is a common problem, and I have read few of the threads. Here is synopsis of my problem.

Logged on to window 8.1, windows installed updates and now grub2 doesn't work

  • Laptop is a Toshiba C55-A
  • Secure boot is disable
  • Turn off fast startup
  • booted with Ubuntu 12.04 LTS Live CD
  • by pressing c accessed grub prompt
  • exited out of grub at which point was able to access boot manager with Windows Boot Manager, Ubuntu, Ubuntu options
  • Selected Ubuntu
  • Booted into Ubuntu
  • sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
  • sudo apt-get install -y boot-repair && (boot-repair &)
  • Selected recommended repair
  • http://paste.ubuntu.com/7743525/
  • http://paste.ubuntu.com/7760191/

The output on boot tab from msconfig (windows command prompt) shows only windows 8.1

The output from the bcdedit is as follows

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.efi
description             Windows 8.1
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}
nx                      OptIn
bootmenupolicy          Standard
detecthal               Yes

Did not see the grub2 menu as expected?

Any other ideas

References

share|improve this question

marked as duplicate by bain, Eric Carvalho, karel, Warren Hill, Radu Rădeanu Jul 8 at 8:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
@bain, thank you for the link which helped arriving at a solution –  Mahendra Gunawardena Jul 7 at 20:17

2 Answers 2

I had this problem too. After updating to Win 8.1, installing boot-repair in ubuntu & running it didn't work for me. (But it was working earlier. Also note that I have to use boot-repair disk after every windows update - every month - since updating to windows 8.1. Before that this problem was not there)

Instead create a bootable usb with boot-repair.

Download iso here: http://sourceforge.net/p/boot-repair-cd/home/Home/

Boot into this & select recommended repair. It will solve the problem.

share|improve this answer
    
I ran the boot repair, but it did not make any changes. I ran it from Ubuntu not from a disk or usb drive –  Mahendra Gunawardena Jul 4 at 10:56
    
No, thats what I said in the answer. Running it from usb instead of installing it in ubuntu solved the problem for me. Create bootable usb and run it. –  Ramanan R Jul 7 at 10:12
    
Thank you for your input, which help me find a solution. –  Mahendra Gunawardena Jul 7 at 15:30
up vote 0 down vote accepted

Following are set of steps to get Grub working after windows 8.1 update on Ubuntu 12.04 LTS

  • Boot computer using live Ubuntu CD and choose "Try Ubuntu"
  • Open a xterm and type the following commands

    sudo add-apt-repository ppa:yannubuntu/boot-repair

    sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-precise.list

    sudo apt-get update

    sudo apt-get install -y boot-repair && (boot-repair &)

  • In boot-repair select the advance options

  • Select the Grub options tab. Secure boot need to be unchecked and press apply

  • Following commands will pop up on a screen. Copy them to terminal and execute the commands.

    sudo dpkg --configure -a

    sudo apt-get install -fy

    sudo apt-get purge -y-force-yes grub* shim-signed

  • Press forward

    sudo apt-get install -y --force-yes grub-efi

  • Press forward

With the above steps grub was re installed.

References

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.