Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have Ubuntu 14.04 and I want to install Windows 8 along side it. But I can't boot from any live Cd or pendrive. My laptop goes into network boot and says- insert proper boot device and press any key.

My laptop is Asus x54c.

share|improve this question

marked as duplicate by Braiam, chaskes, karel, Warren Hill, Eric Carvalho Jul 4 at 10:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4 Answers 4

This is an isse with your BIOS/EFI boot settings. Make sure you have the right settings (CD-Drive/Pendrivve before Network-boot/HDD).

share|improve this answer

Immediately after you restart your laptop, press DEL or F12 or F2 depending upon your laptop model to ender into BIOS settings. Using Arrow keys, select Boot options, and make sure that the USB Disk is set to First Boot device and CD Drive is set to Second Boot device.

Your internal hard disk should be the third on the priority list. Then save changes (Press F10 to save and exit) and exit. This will restart your laptop.

share|improve this answer

Very specific answer to your particular laptop, but which can be useful also for other laptops if you just find out the correct keys:

For everyone who ran into this same problem also:

  1. Plug your USB-memory stick or CD drive into your notebook
  2. Reboot your laptop
  3. Press straight after the first screen comes up which will get you into your BIOS You will see the USB stick as one of the boot options Remember: it speaks for itself that it must be a bootable stick to be able to boot from it

In case you don't see your stick present after following above steps, you might try these next steps out:

  1. Press straight after the first screen comes up which will get you into your BIOS
  2. Go to the 'Boot' tab
  3. In this 'Boot Settings'-screen, use your arrow buttons to move down to 'Boot Device Priority' and press .
  4. (Double)check if you have [Removable Device] enabled as one of the Boot options.
  5. If not, move down to the '3rd Boot Device' and press
  6. Move down to 'Removable Device' and press
  7. When it is set, press [F10] to save your settings and press to confirm.

The notebook will reboot and when everything else is fine, you can pick the memory stick to boot from, using the button after the (re)boot.

share|improve this answer

Your bios is booting from Hard drive before the cd .

1

You can choose the boot by typing F8 keyboard button in the starting.

2

in the starting boot press delete button
you can change this in the bios boot .
you have to make it boot from cd before the hdd .
next time share the bios version .
if you are running linux (ubuntu,fedora,...) use this command

sudo dmidecode -t 0

if you are running windows type in command :

sysinfo

if you are running mac os
you will find it in :

'about this mac' => More Info

you will find the bios version
after you this google it & you will get how to change the boot

share|improve this answer
    
Your instructions are very specific, in reality the keys you need to press and what you need to do can vary widely between motherboard vendors –  JMK Jul 3 at 13:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.