Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

could someone help me resolve this ? I tried most of the commands here .. but none of them worked How do I resolve unmet dependencies?

apt-get install 

The following packages have unmet dependencies:
 libqt4-sql-psql : Depends: libqt4-sql (= 4:4.8.1-0ubuntu4.8) but 4:4.8.2+dfsg-2ubuntu1~precise1~ppa5 is to be installed
                   Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.8) but 4:4.8.2+dfsg-2ubuntu1~precise1~ppa5 is to be installed
E: Unable to correct problems, you have held broken packages.
share|improve this question

1 Answer 1

up vote 0 down vote accepted

It seems like you are using or have been using the kubuntu backports ppa.

Check if you have pinned packages in /etc/apt/preferences.d/ preventing the install of certain package versions.

Then make sure the kubuntu backports ppa is added and updated by running the commands below. Run apt-get install python-software-properties (on Ubuntu 12.04 Precise) if you don't have the apt-add-repository command.

apt-add-repository ppa:kubuntu-ppa/backports
apt-get update

Then try to install the package again:

apt-get install libqt4-sql-psql

If apt is completely stuck and won't let you do the above, you might need to either uninstall the broken package or force install.

apt-get remove libqt4-sql-psql

or

apt-get install -f
share|improve this answer
    
that worked!! thank you! –  canatan Jul 1 at 21:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.