Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Latitude Laptop E6440. The laptop have two interfaces, VGA and HDMI. I connect an external monitor to the VGA port, but when I ran the xfce4-display-settings I see only one monitor (the laptop one ofcourse).

How can I make it to recognize the second monitor ? I already tried booting when it is connected. Still no help.

Here is some info:

I am using Xubuntu 14.04:

Linux 3.13.0-30-generic #54-Ubuntu SMP Mon Jun 9 22:45:01 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I have a dual graphic adapter: One is:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

Second one is:

01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M]

xrandr says:

xxx@dellorian:~$ xrandr 
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1600 x 900, current 1600 x 900, maximum 1600 x 900
default connected 1600x900+0+0 0mm x 0mm
   1600x900       77.0* 

Any idea?

Here is my /var/log/Xorg.0.log post: http://paste.ubuntu.com/7730096/

share|improve this question
    
Could you post your /var/log/Xorg.0.log file somewhere on paste.ubuntu.com? –  Lekensteyn Jun 30 at 20:09
    
Thanks @Lekensteyn posted it here: paste.ubuntu.com/7730096 –  Aviv Jul 1 at 7:20

1 Answer 1

up vote 1 down vote accepted

Your logs suggest that KMS is disabled through the nomodeset option:

[ 4.409] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-30-generic root=UUID=87d0f715-ffb9-454e-a1a8-3233df4fa25e ro nomodeset quiet splash vt.handoff=7

Without this option, the Intel (i915) and radeon video driver won't load, and thus fallback to other, more limited options. You should remove this option, it is probably present in /etc/default/grub. Once changed, you have to run sudo update-grub and reboot.

share|improve this answer
    
Thanks. Hi. I will try without the nomodeset. I think I had another problem without nomodeset: google-chrome did not detect the hardware graphic accelerator and I couldn't use WebGL. –  Aviv Jul 1 at 12:21
    
@Aviv Well, nomodeset is the worst solution for that, it causes everything to be done in software. Did the alternatives (--ignore-gpu-blacklist iirc) not help in that case? Anyway, did the removal of nomodeset fix your problem? –  Lekensteyn Jul 1 at 13:15
    
Yes, It solved the problem. I can see my second monitor. And even chrome://gpu shows "Hardware Accelerator" - Hence WebGL is working ! - Great Job. Thanks. Maybe you can help with my second question ? askubuntu.com/questions/490121/… –  Aviv Jul 1 at 20:19
    
Hey @Lekensteyn - I posted another question quite on topic. askubuntu.com/questions/503118/google-chrome-crashes-in-14-04 Can you please look and read my comment too. It will be very helpful. Thanks. –  Aviv Jul 27 at 11:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.