Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Basically my network won't start. Can't use wired connections.

To make it a further brain-scratcher, when booting into recovery, and using the network console, the network comes up and works. Outside of recovery nothing.

As far as I can tell no settings changed between powering off and on since last time it worked, except for an automatic kernel upgrade. Using an older kernel does not seem to help.

Also this hardware configuration worked perfectly fine for over a year with kernel upgrades and all. Network was always automatic.

Information for follow up questions...

Network manager is running.

Strangely enough, my network interface was never started, nor was DHCP. Where in the configuration can I find this?

To manually resolve the problem:

sudo ifconfig eth0 up
sudo /etc/dhclient

What could have happened in my config to not make this work automatically.

Info gathered:

> lspci | grep net
> 6:00:19.0 Ethernet controller: Intel Corporation 82566DM-2 Gigabit Network Connection (rev 02)

Contents of /etc/network/interfaces

auto lo
iface lo inet loopback

After adding

auto eth0
iface eth0 inet dhcp

the eth0 interface comes up, but the dhclient does not.

--

The problem re-occurred when waking up from sleep.

share|improve this question
    
Is Network Manager running? –  tj111 Sep 29 '10 at 14:53

4 Answers 4

up vote 7 down vote accepted

You are likely missing the line for this in the interfaces file. Open /etc/network/interfaces and check if there is a line for eth0 If not add the following:

auto eth0
iface eth0 inet dhcp

This will add the eth0 interface - and use DHCP on boot and wakeup.

If you're still not getting DHCP response you may also need to add dhcp back into defaults:

sudo update-rc.d dhcp3-server defaults

share|improve this answer
    
Will try this once I can restart computer. Thanks. –  Dmitriy Likhten Sep 30 '10 at 18:59
    
Not working. After a sleep/resume sudo dhclient was still required. The card was up and running though. –  Dmitriy Likhten Sep 30 '10 at 21:29
    
Ok, so just rebooted, network came up automatically. Thanks Marco! –  Dmitriy Likhten Oct 1 '10 at 14:01
    
To make this answer work, I had to insert the auto eth0 stanza above the 'auto lo' that was already there. –  Erigami May 3 '13 at 20:05
    
this should work but don't know why its not working for me –  Wasim Sep 28 at 13:42

I've installed dhcpcd5 and it worked for me.

sudo apt-get install dhcpcd5

share|improve this answer
    
This wont fix the lack of networking on a desktop machine. –  Braiam Aug 3 '13 at 0:31

Could pm-powersave be the cause of your problem? My answer to How to connect wirelessly in a cafe with 11.04 might apply

share|improve this answer

What does ifconfig -a show when it's not working? Is there an eth0? If it's not, I'd check the modules blacklists /etc/modprobe.d/blacklist*. I would have expected the recovery console to honour these though so moving on...

If you do have an interface, it could be some dodgy config inside network-manager. Recovery mode just uses some defaults IIRC so I'd open up the network settings (right click the applet, click edit connections) and check a few things:

  • Connect Automatically is checked
  • You have a MAC address
  • MTU is automatic
  • 802.1x security is disabled
  • IPv4 is set to Automatic (DHCP)
  • Require IPv4 is checked
  • There should be no special routes
  • IPv6 is set to ignore

If ifconfig -a isn't showing an eth0 device, it could be something bizarrely hardware specific. What does lspci | grep net show? If nothing, do you know what the network chipset is?

share|improve this answer
    
ifconfig only shows lo. blacklist only has pcspkr. Network settings interface does nothing. I tried adding a connection the way you described it. –  Dmitriy Likhten Sep 29 '10 at 15:30
    
When network is working, there is no entry in the network connections under wired at all. –  Dmitriy Likhten Sep 29 '10 at 15:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.