Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here is a PROBLEM, a lists of my ATTEMPTS to solve it, and a PLEA for help: [As indicated, I have read all similar 'answered' questions, and have not found an answer that works for me.]

PROBLEM: Constant HIGH CPU Usage: data below=immediately after fresh boot, no apps running CPU0 - CONSTANTLY at some combination which adds up to 100% However ... %CPU in list = between 0 & 20% ... "top" reports Zero 'zombies'

Tasks: 165 total,   1 running, 164 sleeping,   0 stopped,   0 zombie
Cpu0  : 50.0%us, 50.0%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Cpu1  :  1.7%us,  1.0%sy,  0.0%ni, 97.4%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   2055512k total,  1645712k used,   409800k free,   465680k buffers
Swap:  2086908k total,        0k used,  2086908k free,   888712k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
 1074 root      20   0 40488  18m 7800 S    3  0.9   3:39.51 Xorg               
 1745 owlsglob  20   0  245m  55m  25m S    2  2.8   3:49.67 compiz             
14736 owlsglob  20   0 81228  14m  10m S    2  0.7   0:03.10 gnome-terminal     
14802 owlsglob  20   0  2852 1184  892 R    1  0.1   0:03.95 top                
   29 root      20   0     0    0    0 S    0  0.0   0:12.10 kworker/1:1        
 1754 owlsglob  20   0  3716  792  660 S    0  0.0   0:04.59 syndaemon          
 1819 owlsglob  20   0 27192  10m 3084 S    0  0.5   0:09.76 python             
 1847 owlsglob  20   0 63524 5752 3308 S    0  0.3   1:13.09 hud-service

top - 06:03:47 up 1 day, 13:58,  2 users,  load average: 0.16, 0.29, 0.34
Tasks: 170 total,   1 running, 169 sleeping,   0 stopped,   0 zombie
Cpu0  : 80.6%us, 19.4%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Cpu1  :  6.9%us,  1.0%sy,  0.0%ni, 92.1%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   2055512k total,  1039472k used,  1016040k free,   102308k buffers
Swap:  2086908k total,   194356k used,  1892552k free,   538256k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
 1744 owlsglob  20   0  287m  34m  17m S    8  1.7  16:54.45 compiz             
13997 owlsglob  20   0 81804  14m  10m S    6  0.7   0:02.30 gnome-terminal     
 1063 root      20   0 66408  28m  10m S    6  1.4  21:58.16 Xorg               
14060 owlsglob  20   0  2852 1276  980 R    1  0.1   0:02.64 top                
  495 syslog    20   0 31064  884  716 S    0  0.0   0:05.21 rsyslogd

NOTE: This problem began only AFTER a complete reinstall of 12.04. I noticed it following installations and de-installation of ClamAV & Comodo.

ATTEMPTS TO SOLVE THE PROBLEM Scoured "AskUbuntu" and "Ubuntu One"

Biggest 'attempt': Changing NVidia:


Downloaded & installed - [Link deleted - I don't have 10 reputation points]


  • installed Nvidia
    • did NOT solve the problem
    • totally messed up display properties
      • large, unchangeable icons
      • not recognising / could not access my XP partitions
    • Software Centre "removal" made no improvement
    • Synaptic: removed nvidia-304, nvidia-common, nvidia-settings, nvidia-settings-304
      • restart restored previous 'unity' settings * CPU PROBLEM PERSISTS

Considered investigating Xorg: - some links suggest that Xorg is no longer a part of Precise [Link deleted - I don't have 10 reputation points] HOWEVER, it's there on my maching QUESTION - Would adjusting Xorg.conf help to solve the HIGH CPU USAGE?

One post suggests that 'apt-get' might be running in the background ... [Link deleted - I don't have 10 reputation points] QUESTION - Could a program be running in the background, without "top" detecting it?

"CPU 100% - Phantom Usage" - [Link deleted - I don't have 10 reputation points] QUESTION - This post suggests a "zombie process" - BUT ... "top" says 'zero zombies'?!?

One post made suggestions I haven't tried because I can't understand them: [Link deleted - I don't have 10 reputation points]

Also read ... but answers did not seem to apply to my situation: [Link deleted - I don't have 10 reputation points] [Link deleted - I don't have 10 reputation points]

PLEA - Can anyone help me resolve this problem, PLEASE. System: Toshiba NB200 Intel Atom CPU N280 @ 1.66GHz x 2 Graphics - Unknown, OS 32-bit, Disk 16.8 GB Ubuntu 12.04 LTS

Thank you!


share|improve this question
Can you check to see if your system has detected and used the graphics card? You may need to install mesa-utils sudo apt-get mesa-utils then run glxinfo | more You are hoping (in the first couple of pages) not to see lines about using lvmmpipem but instead to see something like OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile –  Charles Green Jun 30 at 15:07
@CharlesGreen That would be sudo apt-get install mesa-utils. –  Jos Jun 30 at 15:45
@Jos Argg - need more coffee --- –  Charles Green Jun 30 at 16:01
@Jos Thank you, Charles Green and Jos for such very clear guidance in getting me this far. "sudo apt-get install mesa-utils" + "glxinfo | more" brought the following (extracted, as you suggested, from the first couple of pages): OpenGL vendor string: Intel Open Source Technology Cente r OpenGL renderer string: Mesa DRI Intel(R) 945GME x86/MMX /SSE2 OpenGL version string: 1.4 Mesa 9.1.7 OpenGL extensions: GL_ARB_multisample, GL_EXT_abgr, GL_EXT_bgra, GL_EXT _blend_color, ... and a LONG LIST of more GL_EXT lines ... MAY I now ask where I (we) go from here? Enjoy that coffee! –  OWLSGlobal Jul 1 at 3:22
The renderer string indicates that you are using the part, and that it thinks this effectively an Intel graphics processor. I'll admit that I'm stumped beyond this point as to what is consuming your CPU time. –  Charles Green Jul 8 at 14:30

2 Answers 2

An Intel Graphics processor uses the main CPU to perform its graphics rendering, so it's basically the kernel eating up these processor cycles...

Solution? Switch to LUbuntu: much less graphics intensive and giving you all the functionality you need to perform all the tasks you need for day-to-day usage (mail, web, and simple games) If you want the look-and-feel of the "real" Ubuntu, you'll just have to live with it...

share|improve this answer

I am happy to report that the problem "solved itself" one day, immediately after a regular Ubuntu 12.04 update. Thank you, Ubuntu team.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.