Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wrote a Bash script which automates the installation of an application based on ERPNext 3.6.1* on my Ubuntu 14.04 LTS laptop.

Part of the script installs required dependencies using apt-get install, which include pip and easy_install. The script worked fine a couple days ago, but now when I try to run it, this step fails with the following error messages from apt-get in the terminal:

Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package easy_install
E: Unable to locate package pip

I cannot find these packages in the Ubuntu Software Center either, although I do still have the commands installed on my system (see below) and a search for either in the Ubuntu Software Center returns the installed package python-pip as the first result.

I also ran the following to try and figure out which package owns the installed commands:

christopher@SkyTemple:~$ whereis easy_install
easy_install: /usr/local/bin/easy_install
christopher@SkyTemple:~$ dpkg -S /usr/local/bin/easy_install
dpkg-query: no path found matching pattern /usr/local/bin/easy_install
christopher@SkyTemple:~$ whereis pip
pip: /usr/bin/pip /usr/bin/X11/pip /usr/local/bin/pip /usr/local/bin/pip2.7 /usr/share/man/man1/pip.1.gz
christopher@SkyTemple:~$ dpkg -S /usr/bin/pip
python-pip: /usr/bin/pip

Did pip and easy_install recently roll into python-pip? Or are they altogether gone now? I need to know how I should update my script, if needed.

* Out of date, I know, but this is what my employer has supplied from our contractor, so I need to work with it.

share|improve this question
    
/usr/local/bin/easy_install indicates this is a local installation of the file, and the file is not managed by dpkg. –  saiarcot895 Jun 30 at 14:37

1 Answer 1

up vote 8 down vote accepted

pip has always been in package python-pip and easy_install in python-setuptools.

Ubuntu 10.04 has a package pip but that's a different program ("Perl Installation Program").

You seem to have installed your own version of setuptools in /usr/local/.

share|improve this answer
    
The /usr/local/ install might be due to an ERPNext-supplied script called further down in my script. The only thing I'm still wondering is why sudo apt-get install pip easy_install worked before with no problems if those packages didn't exist in the first place. –  WarriorIng64 Jun 30 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.