Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't find any suitable driver for the Fuji Xerox DocuPrint C3360.

Fuji Xerox's website does not have any Debian package nor sources, but it has an RPM package. Can I somehow use it on Ubuntu?

Here is the content of the RPM:

├── etc
│   └── cups
│       ├── mimefx.convs
│       └── mimefx.types
└── usr
    ├── lib
    │   └── cups
    │       └── filter
    │           ├── pdftopdffx
    │           ├── pdftopjlfx
    │           └── pstopdffx
    └── share
        └── cups
            └── model
                └── FujiXerox
                    └── en
                        └── fxlinuxprint.ppd

Those directories exist in Ubuntu Natty, so I copied all files to the relevant directories, and rebooted.

Then in Unity's Add Printer dialog, I added the printer's IP adress, it couldn't find a driver so I selected the PPD manually.

Now whenever I try to print, the printer starts making noise, but then the job fails saying "Media tray needs to be filled". I tried with all trays. The trays have abundant paper. Any idea?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

It finally worked! Here is the full procedure:

  1. Download the official RPM, it is the big button at the bottom of this page.
  2. Open it with Archive Manager.
  3. As root, copy all files found in the RPM to their respective directories.
  4. Reboot.
  5. In Unity's Add Printer dialog, select "Network printer" then "LDP", and type the printer's IP address.
  6. It looks for a driver but can't find it, so you are presented with a large list of manufacturers.
  7. Above this list, click the PPD addition button.
  8. Select the fxlinuxprint.ppd you have copied into /usr
  9. In Text Editor, open the Print dialog, in Page setup set Paper source to Tray1, set Paper size to A4.
  10. Press Print, it should print the document after a few minutes, even though "Media tray needs to be filled" errors appear.

UPDATE: If you get a message saying There was an error during the CUPS operation: 'server-error-internal-error', then try with the web interface which runs at http://localhost:631 by default. It worked in my case on Ubuntu 2012.04.

share|improve this answer
    
Why the official RPM link is dead now? :( –  user22659 Aug 2 '11 at 10:07
    
Indeed the link broke after Fuji Xerox incremented the version. I modified my answer, it should work better. –  Nicolas Raoul Aug 2 '11 at 10:18
    
Does not work with 2012.04 :-( "There was an error during the CUPS operation: 'server-error-internal-error'." –  Nicolas Raoul Jun 15 '12 at 7:24
add comment

if you got the .rpm file, you can convert it it to .deb by using alien. quick search resulted this thread that may help

share|improve this answer
    
I don't trust alien too much so I exploded the RPM by myself and copied its files manually. By the way, alien fails saying "fxlinuxprint-1.0.3-1.i386.rpm is for architecture i386 ; the package cannot be built on this system" (I am on 64bit) –  Nicolas Raoul Jun 16 '11 at 9:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.