Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm pretty new to ubuntu and am having some problems with samba. I am using XBMCbuntu and I have a few shares which I share with my family and some that I don't. You can see this in my config file.

[global]
workgroup = WORKGROUP
server string = %h server (Samba, XBMC)
netbios name = XBMC
dns proxy = no
name resolve order = hosts wins bcast
guest account = scrub
load printers = no
show add printer wizard = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d
encrypt passwords = true
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n $
pam password change = yes
map to guest = bad user
force user = matt
force group = matt

[Pictures]
path = /home/matt/hdd1/Pictures
comment = Pictures
writeable = yes
browseable = yes
guest ok = yes

[System]
path = /home/matt/.xbmc
comment = XBMC System Share
valid users = matt
writeable = yes
browseable = yes
guest ok = no

[Root]
path = /
comment = Root acess
valid users = matt
writeable = yes
browseable = yes
guest ok = no


[Other]
path = /home/matt/hdd1/other
comment = other
valid users = matt
writeable = yes
browseable = yes
guest ok = no

The "pictures" share is working correctly, anyone can read/write to it. The "system" share is working correctly, only I can read/write to it.

However the "root" and "other" shares don't work as I want, I am the only one who can read but I can't write.

I've tried changing some file system permissions but I'm not too familiar with them and I'm not convinced that is the problem.

Any help would be awesome.

share|improve this question
    
You say you have tried changing some file permissions, but have you tried changing directory permissions? –  boon Jun 30 at 12:43

1 Answer 1

up vote 0 down vote accepted

Hivemind, Your samba configuration looks correct, so my best guess would be file-system permissions. Your user, "matt", may not have access to write to those directories. Are you able to navigate to another folder you can write to from your root share? (Note: sharing the root of your filesystem is not the best idea in the world.) If so, then it almost certainly is file-system permissions, and if you do need to have write-access to a folder, your best bet will be chmod commands. A good tutorial on those can be found here:

http://www.linux.org/threads/file-permissions-chmod.4094/

Note that this should be done with caution, and selectively.

share|improve this answer
    
Thanks. It was the folder permissions. The users and groups were all wrong but I got them straightened out and now its working well. –  Hivemind Jun 30 at 13:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.