Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Installing grub2 fails on my system (10.4 64Bit) with:

/usr/sbin/grub-probe: error: cannot find a GRUB drive for /dev/sdaq1.  
 Check your

Checking, it only lists hd0 to hd25 corresponding to sda to sdz. Recreating the device map produces the same result. How do I get grub to recognize /dev/sdaq1.

Note: The machine has many, many devices; sdaq is the correct drive.

share|improve this question

1 Answer 1

You need to patch grub-installer.

See bug report 776633 for a patch:

Index: grub-installer-1.60ubuntu3/grub-installer
--- grub-installer-1.60ubuntu3.orig/grub-installer  2011-05-03 12:00:57.553509999 -0700
+++ grub-installer-1.60ubuntu3/grub-installer   2011-05-03 12:04:02.873000831 -0700
@@ -286,7 +286,7 @@
-    /dev/[hsv]d[a-z]|/dev/xvd[a-z]|/dev/cciss/c[0-9]d[0-9]*|/dev/ida/c[0-9]d[0-9]*|/dev/rs/c[0-9]d[0-9]*|/dev/mmcblk[0-9]|/dev/ad[0-9]*|/dev/da[0-9]*)
+    /dev/[hsv]d[a-z]|/dev/[sv]d[a-z][a-z]|/dev/[sv]d[a-z][a-z][a-z]|/dev/xvd[a-z]|/dev/cciss/c[0-9]d[0-9]*|/dev/ida/c[0-9]d[0-9]*|/dev/rs/c[0-9]d[0-9]*|/dev/mmcblk[0-9]|/dev/ad[0-9]*|/dev/da[0-9]*)

grub-installer is probably not on your system (since after it's in installed there's not really need for it to stay ;) ). This is the package it concerns: so you'll probably find it on the install medium...

Here's a quick how to on remastering your own CD: How can I easily remaster Ubuntu?

share|improve this answer
Sounds like the right direction. I'm however not sure how to apply the patch: I tried to install grub2 with apt-get install and there does not seem to be a file with name grub-installer on my system when doing this. –  user7054 Jun 16 '11 at 5:02
Thanks for the additional info. In my case the problem occurred during a kernel upgrade, not a new installation, on a system that has a lot of staff installed and is running in a semi-production environment. So, I'd rather not do a re-install if at all possible. –  user7054 Jun 17 '11 at 0:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.