Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have used Windows XP for years. I partitioned my HD with 300 GB for XP and 1 TB for Ubuntu. I installed v.14.04 successfully. When booting I get a menu choice defaulting to Ubuntu and then XP. Selecting XP only brings me back to the boot menu. Can the XP boot be repaired. As it is I can only get to my XP data through Ubuntu. I would like to have a choice that works. I could not install Ubuntu along side XP because the only given choice was another HD not the partition.


Update

I ran boot-repair and TestDisk trying to repair bootup. Now I get grub recovery> and running my installation disk for Ubuntu gets to the Ubuntu window with the five moving dots and locks up. I have no idea what commands to use with grub recovery> and I can't get to a terminal without Ubuntu running.

I did try to recover Windows XP boot without reloading XP thinking it might repair the BIOS. I also ran chkdsk /R. None of this helped; I got the same result.

Thanks in advance for any suggestions.

share|improve this question
    
You can usually open a text-only console from the Ubuntu window with the five moving dots and login and run terminal commands to fix your boot problem from the console. Look at this question: How to switch to a command-line console in order to run the commands in Low Graphics mode?. –  karel Jul 11 at 0:53

2 Answers 2

You should be able to restore XP by performing a "Chkdsk -f" from a Windows command prompt. Now of coarse since you are unable to open XP itself, you will need to get to the cp using a Windows installation disk, or a boot disk like Active@ Boot Disk by lsoft. Unfortunately you cannot perform a Chkdsk from Linux.

share|improve this answer
    
This will remove Grub and prevent booting into Ubuntu. And you can perform chkdsk from linux; run the command fsck.ntfs /dev/<windows partition> –  aroll605 Jun 30 at 4:01

Probably something wrong with GRUB.

Try re-installing your bootloader (GRUB).

Run the following in your terminal on Ubuntu:

sudo grub-install /dev/sda
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.