Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to mount my USB hard drive as myself, or in my group, whatever it takes to be able to move stuff onto the disk without sudo.

I have tried setting up a rule in /etc/udev/rules.d/mountasuser.rules (also tried the filename 99-mountasuser.rules).

The contents of that file:

KERNEL=="sdb2" SUBSYSTEM=="block" GROUP="me"

I've tried lots of different setups in this file, because my original intention was to make it more general, since I pretty much want any external drive to be writable by me. Since those more general versions didn't work, I kept trying to simplify until I had the rule above.

This drive won't be connected all the time so fstab is not a good choice. The version of Ubuntu I have (14.04) doesn't have the udevinfo command, and running sudo udevadm info –query=all -n /dev/sdb2 –attribute-walk doesn't output things in the same format, so maybe I'm not selecting my drive correctly in the udev rules, but my rule is so simple, that doesn't make sense.

The output of udevadm info: http://paste.ubuntu.com/7723273/

share|improve this question
    
Can you try to run fsck (probably you will need also the options -w and -r) on the unmounted device to see if it has any errors. If this is the case it would be mounted as readonly. –  Arian Bär Aug 27 at 9:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.