Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have configured Ubuntu 14.04 LTS so I am able to xrdp from a Windows 7 PC into the xfce desktop, unfortunately the xfce desktop only shows for one specific Linux user, if I RDP to the box with another user then the screen is just grey with the X cursor. Any ideas please?

share|improve this question

1 Answer 1

I have used xrdp extensively on earlier versions of Ubuntu and usually found that connection issues were quite simple in the end. In my case it was always something minor that was the snag. So when I bumped into the problem on two of my boxes upgraded to 14.04 I guess I knew instinctively that it would probably just be a need for some simple variation to earlier solutions. Which is exactly what I discovered in my case.

Literature in the public domain was quick to point out that xrdp does not work on 14.04 with the 'out of the box' desktop/s. The loss of the rollup window function had already steered me back to the xfce4 desktop, so I thought my earlier knowledge would fix the grey screen straight off. As it turns out the adjustment is in the same place but just a little different.

As an aside you may first need to turn off the uncomplicated firewall (stop ufw) just to be sure that is not contributing to the problem. The login script may stall if the firewall is filtering the exchange of data. After you fix xrdp you can figure out if there is a need to make some adjustments there.

THE FIX: edit /etc/xrdp/startwm.sh

make the last two lines look like this;

    #. /etc/X11/Xsession
    . /usr/bin/startxfce4

(In earlier versions I used the statement session=xfce4-session)

Save the file and restart xrdp, and you should find you have a perfectly well behaved remote desktop session.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.