Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using two monitors of different brands and resolutions with NVIDIA TwinView, which works well enough, but one thing that's getting to me is how the mouse can move off the edge of the visible screen space below the left-hand screen and above the right-hand screen (see screenshot).

It makes it much more difficult to hit buttons at the bottom/top of each screen, since the cursor just disappears off the edge. Is there a way of changing this behaviour?

share|improve this question
up vote 3 down vote accepted

The mouse moving into those dead areas is a known X bug however there is a workaround using XCreateMouseVoid that I have detailed in this question:

If you wish to just align the monitors along the top or bottom edges then modify the Absolute Position from +1920+90 to +1920+0 or +1920+56

share|improve this answer
This works perfectly, thanks! – Will Vousden Jun 16 '11 at 8:58

Since you're using Nvidia binary driver you can put:

Option "ConstrainCursor" "yes"

In the screen section of your xorg.conf. Indeed, this is the default behaviour.

This will prevent the mouse from entering any of the voids. However, it also prevents you from revealing the launcher by "pushing" against the edge of the screen, if you use Unity.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.