Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 14.04 (64 bit). In my previous Ubuntu, which was 12.04, when the screen was locked and the monitor went blank, I just typed the password and hit enter. Even though everything looked blank, it worked in the background and unlocked the screen. However, in 14.04, when I directly type the password from the lock screen (with the monitor out), often times it misses the first character and obviously tells me that the password is wrong. So now I have to type the first character, wait a bit for the screen to come up and see if it was registered, and then type the rest of the password depending on that. Not that big of an issue, but for someone who locks the screen almost every time he leaves the PC, it's a little annoying.

Any way to fix this?

share|improve this question

1 Answer 1

Are you using a wireless keyboard? I think this has something to do with the keyboard (and/or keyboard driver) "sleeping" if it is not used for few minutes. This only seems to occur on my first attempt at entering my password, or if I haven't hit any keys for awhile.

I would think this is most likely an issue with my keyboard. It is a cheap wireless keyboard by Logitech. It probably has some built-in sleep mode to conserve battery. Higher-end keyboards may have built-in "turn on and send first entry" process. I don't know. Just what I have observed.

Maybe try getting in the habit of waking your machine via keystroke? (Hit 'Enter' to wake instead of moving your mouse...)

share|improve this answer
    
I am using a USB keyboard. Well same for me, the keyboard itself seems to go to sleep after a while. So the first keystroke just wakes it up and the second keystroke registers as a character input. So if I directly type my password "123456", it just inputs "23456" and ignores the "1". The problem is, it does not happen ALWAYS, otherwise I would just input "1123456" with the first extra "1" working as the 'waker'. –  LonelyKing Jul 16 at 5:45
1  
For sure. I will mess around with my computer some more and see if I can figure it out. I will let it sleep for an hour or so and see if it is unresponsive with that first keystroke. I HAVE ALSO had times on my previous Ubuntu 14.04 LTS install where I could not input my password at all. I had to hit 'Switch Accounts' and enter it there to login. So this sleeping keyboard theory of mine may or may not be the problem lol. Will try to post findings here later on :) Good luck! –  derekmx271 Jul 21 at 4:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.