Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to setup a public share with Samba so I can stream my music files from my Ubuntu 14.04 server to my Sonos soundsystem. Been trying to crack this one for a couple of hours, but unfortunately no success. I've set the following share in smb.conf:

[global]
security = user
map to guest = bad user
guest account = nobody

;  interfaces = lo p2p1
;  bind interfaces only = true

[public]
comment = Public Share
path = /export/storage
browseable = yes
read only = yes
guest only = yes
guest ok = yes

The output in testparm looks good at first sight, but both the browseable & read only setting aren't visible:

[global]
server string = %h server (Samba, Ubuntu)
server role = standalone server
map to guest = Bad User
obey pam restrictions = Yes
pam password change = Yes
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
usershare allow guests = Yes
panic action = /usr/share/samba/panic-action %d
idmap config * : backend = tdb

>>> not using printers / nor touched the settings, hence the skip <<<

[public]
comment = Public Share
path = /export/storage
guest only = Yes
guest ok = Yes

------END-------

Basically, both the browseable = yes and read only = yes aren't showing up. Have a funny feeling that this is causing my other devices in the Network not being able to connect to the samba share directory.

More specifically, I can add smb://192.168.0.xxx/export/storage and my Mac will recognize the server and try to connect. But when I try to login as a guest user, it doesn't make the connection and tells me to contact the system administrator, which is funny in its own way... ;-)

Tried to connect with other devices and have the same problem. On a foot note, set up a NFS server earlier today and have no problems whatsoever connecting devices to the same 'shared' directory.

Really struggling with this one, any help or point into the right direction is much appreciated.

share|improve this question

1 Answer 1

Finally found the answer to the problem. I made a big mistake with the server address on my clients. I was pointing to the directory /export/music, but should've been pointing to the share itself [music], which is mentioned in /etc/samba/smb.conf

Problem = smb://192.168.0.200/export/music

Solution = smb://192.168.0.200/music

Anyway, it's all working now :-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.