Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Latitude Laptop E6440. The laptop have two in4terfaces, VGA and HDMI. I connect an external monitor to the VGA port, but when I ran the xfce4-display-settings I see only one monitor (the laptop one ofcourse).

How can I make it to recognize the second monitor ? I already tried booting when it is connected. Still no help.

Here is some info:

I am using Xubuntu 14.04:

Linux 3.13.0-30-generic #54-Ubuntu SMP Mon Jun 9 22:45:01 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I have a dual graphic adapter: One is:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

Second one is:

01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M]

xrandr says:

xxx@dellorian:~$ xrandr 
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1600 x 900, current 1600 x 900, maximum 1600 x 900
default connected 1600x900+0+0 0mm x 0mm
   1600x900       77.0* 

Any help ? 10x.

share|improve this question

4 Answers 4

Make absolutely sure the cable is connected fully, I've had several that SEEM to be connected but are only partially connected. If that isn't the problem then it may be just that you do not have the correct drivers installed, run "sudo drivers autoinstall" to try to correct this

share|improve this answer

What I did to fix this was open up system settings, even blindly if you can't see one of the screens.

Change the resolution of the monitor not working, apply changes. Both my monitors worked at this point. You can now change the resolution back.

share|improve this answer
    
Not sure if relevant, but I'm using GNOME 3 instead of Unity. –  kernel_creator Jun 28 at 19:15
use xrandr --auto

you can use the above command this will help you to detect desktop and other screen

share|improve this answer

Update:

I just realized that even though our laptops are similar (E6440 vs E6430), we have different integrated video cards (yours has ATI, mine Nvidia), so my original answer is practically useless to you. However, I did have the same issue as you in that I could not get extra monitors to be recognized or configured and xrandr was not reporting anything useful.

So, that being said, I believe your issue is with your driver. I couldn't find which driver is appropriate for your card, but perhaps you will have better luck finding it.

Here is Ubuntu's list for Radeon Drivers: https://help.ubuntu.com/community/RadeonDriver

Here is a wiki for installing ATI binaries: https://help.ubuntu.com/community/BinaryDriverHowto/AMD

I hope that helps.

Edit: Old answer below, for reference.

I had a similar problem. I have a Dell Latitude E6430 running Ubuntu 14.04 with Gnome 3.10 and GDM.

#uninstall bumblebee and nvidia drivers
sudo apt-get purge bumblebee* nvidia*

#reinstall nvidia 331 
#(the only driver that apparently works correctly with my video card)
sudo apt-get install nvidia-331 nvidia-settings nvidia-prime

#restart
sudo reboot

After rebooting, xrandr was able to detect all my display ports again and my previous settings found in ~/.config/monitors.xml were loaded automatically.

You may also consult this page for more help with further configuration: http://xmodulo.com/install-configure-nvidia-optimus-driver-ubuntu.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.