Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I am trying to install Windows 7 on an old system, which had Ubuntu 12.10 on it. I accessed the drive with a cradle and deleted the partitions off of it, then formatted it to NTFS (For Windows). Popped it back in the system and tried to boot from CD to install Windows 7 and I get:

error: unknown filesystem
grub rescue > 

How did GRUB even survive the formatting and how can I get rid of it for good so I can do a fresh install of Win 7?

share|improve this question

marked as duplicate by bodhi.zazen, user68186, Warren Hill, Mitch Jun 30 at 10:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Just do a fresh install of Windows. The windows installer will format the hard drive and take care of GRUB. –  bodhi.zazen Jun 27 at 17:06

1 Answer 1

Format the drive using gparted and creating a new partition table in the MBR format. That will completely wipe the disk of grub, though it really won't affect your ability to boot to the disk drive, try pressing f12 at boot when the bios screen comes up and select cd drive. Wiping grub off the disk is done by the windows installer, and it does nothing to obstruct the cd boot process.

share|improve this answer
    
I completely changed the boot order to exclude everything but the cd and have manually changed the boot device with f12 with no new results, unfortunately. Forgive my ignorance on the subject, but what is gparted and if I cant boot into Win 7 via USB or CD how can I use gparted? –  user298426 Jun 27 at 22:02
    
I though you were able to boot from the ubuntu cd, if you can't I don't know what to tell you. If it still goes to grub rescue it means it's still booting from the hard drive –  sbergeron Jun 27 at 22:04
    
hadnt even tried ubuntu until you mentioned that. however, upon trying it with ubuntu 12.10 live disk, it failed with the same error. –  user298426 Jun 27 at 23:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.