Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 14.04 64bit dual booted. When I connect something on front audio jack then rear audio is not working. I have tried changing analolog-output-headphones.conf file. After changing that alsamixer showing that both centre and surround not muted with full volum. Unfortunately no audio.

aplay -l
    **** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
share|improve this question

1 Answer 1

I have the same problem. When headphones are connected to front jack, ubuntu automatically turn off speakers. It is not configurable from the alsamixer... when front jack is connected, works only front jack. I'm very often using toggle between headphones to speakers, in ubuntu 12.04 it works programmatically but in 14.04 can only disconnect front jack, to use speakers. It is really frustrating, why its not configurable?

[EDIT]

In alsamixer Auto-Mute Mode [Enabled/Disabled] worked for me, it toggle headphones and speakers, when front jack is connected, like a charm.

share|improve this answer
2  
Welcome to Ask Ubuntu! You've posted this as an answer, and (as of your edit) this does seems like it is at least in part an answer to the question. But it's worded as though you're asking a separate, related question. To make this clearer for people searching for help (so they know this post might help them), and to decrease the likelihood that this post will be considered not-an-answer and deleted, I recommend rewording this, and also removing anything that's actually a question you want answered (rather than a proposed solution) and posting it as one. –  Eliah Kagan Aug 25 at 0:07
    
@yeneq6 That didn't work, Even changing with alsamixer is not working. –  Shanoop Aug 25 at 6:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.