Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having some trouble having an Internet connection on 4G with Ubuntu (latest version, latest kernel).

I had no trouble making my Huawei E3276 LTE dongle work.

Now I'm trying to connect my computer to the Internet using a Huawei ME909u-521 module, with a MiniPCIe to USB adaptor.

I suspect this is a driver problem. I searched the web for a driver without any success. The huawei website does provide some guidelines on what seems to be a "how to code your own driver..." but there is no Linux driver available as advertised.

Here is the dmesg info :

[ 1766.351068] usb 5-1: new low-speed USB device number 54 using uhci_hcd
[ 1766.464078] usb 5-1: device descriptor read/64, error -71
[ 1766.678066] usb 5-1: device descriptor read/64, error -71
[ 1766.881082] usb 5-1: new low-speed USB device number 55 using uhci_hcd
[ 1766.994077] usb 5-1: device descriptor read/64, error -71
[ 1767.208033] usb 5-1: device descriptor read/64, error -71
[ 1767.411044] usb 5-1: new low-speed USB device number 56 using uhci_hcd
[ 1767.819191] usb 5-1: device not accepting address 56, error -71
[ 1767.921066] usb 5-1: new low-speed USB device number 57 using uhci_hcd
[ 1768.329088] usb 5-1: device not accepting address 57, error -71
[ 1768.329129] hub 5-0:1.0: unable to enumerate USB device on port 1
[ 1768.535093] usb 5-1: new low-speed USB device number 58 using uhci_hcd
[ 1768.648053] usb 5-1: device descriptor read/64, error -71
[ 1768.862037] usb 5-1: device descriptor read/64, error -71
[ 1769.065125] usb 5-1: new low-speed USB device number 59 using uhci_hcd
[ 1769.178099] usb 5-1: device descriptor read/64, error -71
[ 1769.392092] usb 5-1: device descriptor read/64, error -71
[ 1769.595100] usb 5-1: new low-speed USB device number 60 using uhci_hcd
[ 1770.003041] usb 5-1: device not accepting address 60, error -71
[ 1770.105070] usb 5-1: new low-speed USB device number 61 using uhci_hcd
[ 1770.513045] usb 5-1: device not accepting address 61, error -71
[ 1770.513073] hub 5-0:1.0: unable to enumerate USB device on port 1
[ 1773.828100] hub 5-0:1.0: unable to enumerate USB device on port 1
[ 2734.160199] usb 5-1: new low-speed USB device number 63 using uhci_hcd
[ 2734.274127] usb 5-1: device descriptor read/64, error -71
[ 2734.540109] usb 5-1: device descriptor read/64, error -71
[ 2734.743050] usb 5-1: new low-speed USB device number 64 using uhci_hcd
[ 2734.856053] usb 5-1: device descriptor read/64, error -71
[ 2735.071082] usb 5-1: device descriptor read/64, error -71
[ 2735.274102] usb 5-1: new low-speed USB device number 65 using uhci_hcd
[ 2735.683081] usb 5-1: device not accepting address 65, error -71
[ 2735.785059] usb 5-1: new low-speed USB device number 66 using uhci_hcd
[ 2736.194079] usb 5-1: device not accepting address 66, error -71
[ 2736.194115] hub 5-0:1.0: unable to enumerate USB device on port 1

Lsusb doesn't return any entry matching with the device. Any advice on what to do to make this thing work ?

Thanks for your help !

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.