Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sometimes I wonder if there's a conspiracy to kill Gnome Flashback because it feels like it's been constantly beset with problems since the emergence of both Gnome 3's new look and Unity.

As in a previously question, after an update, I couldn't log in, and and it turned out to be the fault of malformed packages.

Now, after another update, my windows don't have any decoration (no frame with the program title and the close, minimize and maximuze buttons). It's also made my iBus input switching no longer respond to my shortcut keys (which I'll address in a separate question if it persists).

How do I get my window decorations back?

And is Gnome Flashback being supported anymore? It just seems like it's slowly breaking.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It should probably be using gtk-window-decorator for decorations. If that isn't loading, perhaps Metacity (the wider window manager) hasn't loaded properly either.

I'd start by running metacity --replace in a run box, terminal or whatever you can get your hands on. If you need to use a TTY, remember to set export DISPLAY=:0 first.

If that works, it's a case of getting that to load on start. I'm afraid I've no idea what the start-up sequence is like on Flashback but if you have a Start Up applications, sticking a record in there for Metacity might work.


Whether or not it's maintained is a slightly more difficult question to answer. There certainly seem to be a number of people milling around it and there's a fair bit of detail on its wiki page. The mailing list also gets a fair amount of traffic. Yeah, I'd say it's alive.

But how fast they'll turn around any of these problems is anybody's bet. You might have more luck on an actual Gnome 2 fork rather than trying to emulate it with Gnome 3. MATE seems plenty active and it had a fairly solid base to grow off.

share|improve this answer
    
metacity --replace worked perfectly. Thanks so much for that. I'll load it manually for a little while, in hopes that it'll be solved in a future update. Also thanks for your insights about Flashback. I tried MATE for a while and found it limited in that it doesn't have the same amount of support for panel applets and other peripheral features, so I gave up on it. I did love the Mint Menu, though, so I might go back. I just wish there was one interface that had all the support and features I wanted... Oh well... one can dream. ;) –  Dave M G Jun 27 at 13:19
    
Unfortunately, after using this for a while, I've learned that whle metacity --replpace does get my window frames back, it also kills all other Compiz features, some of which I was using. So I guess I need to look for another solution. I'll start a new question, though, since this answer did resolve the issue I was having when I asked it. –  Dave M G Jul 13 at 1:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.