Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I just installed Ubuntu 14.04, since it's summer vacation and I need something to play with :D

I have installed Steam, no problem. But when I went to install ClamAv with ClamTk just for good measure, I got a threat from a file in the steam directory when I scanned. I am using the GUI for ClamAv, and the file is located /home/(myuser)/.local/share/Steam/resource/sourceinit.dat the status is PUA.Win32.Packer.PrivateExeProte-7 and it says action taken none.

When I first got the threat I just said to delete/quarantine it, but when I restarted steam and scanned again it had reappeared. So Im wondering if it a false positive or something?

Also, when I try to update clamav it the says the following:

sudo freshclam
ClamAV update process started at Fri Jun 27 00:10:51 2014
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.98.1 Recommended version: 0.98.4
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cvd is up to date (version: 55, sigs: 2424225, f-level: 60, builder: neo)
daily.cvd is up to date (version: 19132, sigs: 1054516, f-level: 63, builder: neo)
bytecode.cld is up to date (version: 242, sigs: 46, f-level: 63, builder: dgoddard)

Is this nothing to worry about or something that shouldn’t be handled?

share|improve this question

1 Answer 1

Referring to this, and past experiences, ClamAV will throw this if it find something packed by something that could used by those that make malware - this can include installed exe's, dlls etc. This probably is just designed to make sure you know something potentially dangerous is there that it might not be able to detect - e.g. from here:

Packed

This is a detection for files that use some kind of runtime packer. A runtime packer can be used to reduce the size of executable files without the need for an external unpacker. While this can‘t be considered malicious in general, runtime packers are widely used with malicious files since they can prevent a already known malware from detection by an Antivirus product.

As for the version error, it says to check the FAQ as it says there that the packages provided by them are the latest version, but the version provided from the OS's repos may work the best for that OS as it has been built specially for it. I think this is fine as long as you update the signatures (stuff about that is alsp in the FAQ and documentation). See also: http://clamtk.sourceforge.net/help/faq-clamtk.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.