Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Does anyone know of a way to disable application switching when the scroll wheel gets bumped while the mouse is hovering over the Cairo Dock?

I don't see any options for this in the settings, but it's a fairly annoying "feature" that I'm hoping someone else has found a way to turn off.

share|improve this question
    
Do you mean when the mouse is over an application icon, it switches windows of that application? Or when the mouse hovers in between the icon on the dock itself, it switches between applications? –  Aibara Iduas Sep 1 at 19:07
    
When I hover the mouse over the application icons in the Cairo-dock (so my mouse is right over chrome's icon, for instance) and I scroll the mouse scroll wheel, or do a two finger scroll on my track pad, cairo-dock interprets that as a me wanting to activate that application and it then gives that application the focus. I can't find a way to turn this off in the settings, and this is literally the only thing that I don't like about this dock. –  rmmoul Sep 1 at 19:13
    
@AibaraIduas This doesn't start an application that isn't already running, though. It only works for an application that already has a window open. –  rmmoul Sep 1 at 19:14
    
Gotcha. I don't see a way to disable it in the settings, but will keep searching. Though I'm having trouble getting the dock to even run properly on my current setup. –  Aibara Iduas Sep 1 at 19:24
    
@AibaraIduas I thought about setting up a per-app mouse wheel shortcut to override the setting (askubuntu.com/questions/516847/…) but I couldn't find anything to help me there, either. –  rmmoul Sep 1 at 23:26

1 Answer 1

up vote 1 down vote accepted
+50

Unfortunately, despite the plethora of options available to customize Cairo-dock, the ability to turn off application switching with the scollbar is not one of them. It seems that there's no way to turn it off because it's considered a basic feature (see the description of Cairo-Dock's taskbar on this page), one that is found in other desktop environments as well (e.g. Unity works the same way if the applications are open on the same workspace).

To remove the functionality you will have to recompile the source, as explained in an answer on the Cairo-Dock forums. User matttbe provided a links on how to recompile Cairo-Dock (and specifically how to do so in Ubuntu) and stated that to disable all actions that will occur after scrolling on an icon remove these lines below from the src/cairo-dock.c source file:

gldi_object_register_notification (&myContainerObjectMgr,
    NOTIFICATION_SCROLL_ICON,
    (GldiNotificationFunc) cairo_dock_notification_scroll_icon,
    GLDI_RUN_AFTER, NULL);
share|improve this answer
    
This is such a shame. I'll never understand why developers include things like this without providing a way to turn it off (I'm also looking at you, chrome). I guess this is as good as it gets. Thanks for linking to the cairo-dock forums. –  rmmoul Sep 2 at 23:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.