Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The hardware is present:

$ lspci | grep Centrino
04:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)

And the Bluetooth, iwlwifi, and iwldvm modules get loaded:

$ lsmod | egrep 'iwl|blue'
iwldvm                232285  0
mac80211              626557  1 iwldvm
iwlwifi               169932  1 iwldvm
bluetooth             395423  10 bnep,rfcomm
cfg80211              484040  3 iwlwifi,mac80211,iwldvm

Indeed, there's bluetooth output in my startup log:

$ dmesg | egrep -i 'iwl|blue'
[    2.598945] Bluetooth: Core ver 2.17
[    2.598994] Bluetooth: HCI device and connection manager initialized
[    2.599006] Bluetooth: HCI socket layer initialized
[    2.599010] Bluetooth: L2CAP socket layer initialized
[    2.599016] Bluetooth: SCO socket layer initialized
[    2.637552] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    2.637557] Bluetooth: BNEP filters: protocol multicast
[    2.637570] Bluetooth: BNEP socket layer initialized
[    2.683477] Bluetooth: RFCOMM TTY layer initialized
[    2.683493] Bluetooth: RFCOMM socket layer initialized
[    2.683501] Bluetooth: RFCOMM ver 1.11
[    2.802024] iwlwifi 0000:04:00.0: enabling device (0000 -> 0002)
[    2.802106] iwlwifi 0000:04:00.0: can't disable ASPM; OS doesn't have ASPM control
[    2.802169] iwlwifi 0000:04:00.0: irq 106 for MSI/MSI-X
[    2.829897] iwlwifi 0000:04:00.0: loaded firmware version op_mode iwldvm
[    2.981631] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEBUG disabled
[    2.981638] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[    2.981640] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[    2.981644] iwlwifi 0000:04:00.0: Detected Intel(R) Centrino(R) Advanced-N 6235 AGN, REV=0xB0
[    2.981921] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[    3.054692] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'

And the wifi portion of the card is working great! However, the bluetooth device isn't coming up at all— doesn't show up for hcitool, hciconfig, or rfkill, eg:

$ hcitool dev
$ sudo rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

I'm on a 64-bit machine, running a headless minimal Ubuntu 14.04:

$ lsb_release -r
Release:    14.04
$ uname -a
Linux test 3.13.0-29-generic #53-Ubuntu SMP Wed Jun 4 21:00:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I briefly tried the 3.14 kernel, which seemed no different. I also tried removing and reinserting the the iwlwifi and bluetooth modules. I've also confirmed the same behaviour as above in the 14.04 live desktop.

Would appreciate additional thoughts or pointers, thanks.

One additional piece of data is syslog output related to bluetoothd:

$ sudo cat /var/log/syslog | grep -i bluetoothd
Jun 26 15:09:54 jackal2 bluetoothd[476]: DIS cannot start: GATT is disabled
Jun 26 15:09:54 jackal2 bluetoothd[476]: Failed to init deviceinfo plugin
Jun 26 15:09:54 jackal2 bluetoothd[476]: Failed to init proximity plugin
Jun 26 15:09:54 jackal2 bluetoothd[476]: Failed to init time plugin
Jun 26 15:09:54 jackal2 bluetoothd[476]: Failed to init alert plugin
Jun 26 15:09:54 jackal2 bluetoothd[476]: Failed to init thermometer plugin
Jun 26 15:09:54 jackal2 bluetoothd[476]: Failed to init gatt_example plugin
Jun 26 15:09:54 jackal2 bluetoothd[476]: Bluetooth Management interface initialized

Are these plugin failures something to investigate? What is GATT?

I have determined now that this radio and driver work fine with wifi and bluetooth on a different motherboard, so I'm assuming it's a hardware conflict with something on the particular motherboard (a Gigabyte J1800N-D2H).

Curiously, the same problem persists on a different J1900 motherboard, leading to suspicion that this is a chipset conflict. This time the dmesg log is showing a firmware crash on startup, which I don't recall seeing previously. The log and lshw output are in a gist here:

share|improve this question

To answer your question:

"Are these plugin failures something to investigate? What is GATT?"

As far as your first question goes googling reveals pretty much everyone seems to be disabling bluetooth and 802.11n on the Intel Centrino Advanced-N 6235 PCI-e Wifi Adapter.

I would ignore the errors unless you actually need bluetooth to work.

As far as your second question the answer (which I don't care to know) is below.

Generic Attribute Profile (GATT) is built on top of the Attribute Protocol (ATT) and establishes common operations and a framework for the data transported and stored by the Attribute Protocol. GATT defines two roles: Server and Client. The GATT roles are not necessarily tied to specific GAP roles and may be specified by higher layer profiles. GATT and ATT are not transport specific and can be used in both BR/EDR and LE. However, GATT and ATT are mandatory to implement in LE since it is used for discovering services.

share|improve this answer
up vote 0 down vote accepted

This has finally been figured out. The issue is that the bluetooth function of the 6235 is supplied by a separate interface, over the USB connection in the MiniPCIe port. Neither the J1800 or J1900 motherboards I am using have the USB portion of the MiniPCIe port connected.

share|improve this answer

Centrino Advanced-N 6235 works great in my HP DV6-7010US on Ubuntu 14.04. The bluetooth did not work initially and was unable to find any solutions in the forums. I saw a review on Amazon where they said FN + F3 was needed to choose between Wifi, Wifi+Bluetooth, or neither on an Acer. On my HP that combination didn't work so I pressed F12 a couple times and the bluetooth indicator appeared. Now everything is working as it should.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.